CHAPTER

Creating Layout
Standards

¢+ 0+ 0+

In This Chapter

Automating repetitive

I hink for a moment about the publications you produce. tasks

Chances are that most of your work involves creating
multiple iterations of a basic set of publications, and each
publication looks more or less the same from issue to issue.
For example, periodicals such as newsletters, magazines, and pages
newspapers don’t change much from one issue to the next
(disregarding the occasional redesigns that all publications
undergo). The ongoing uniformity of such things as page size, . .
margins, page layouts, text formats, even the tone of the writ- Using libraries
ing, gives each publication a unique look and feel.

Working with master

Creating templates

Working with other

If you had to start from scratch every time you created a pub- page-layout tools
lication, you’d spend the bulk of your time setting up your
documents and have little time left to attend to the appear- LA S S o

ance of the content (you’d probably get terribly bored, too).
Few things are less rewarding than doing the same job over
and over. Fortunately, InDesign includes several extremely
useful features that let you automate repetitive tasks. This
chapter focuses on three of them — master pages, templates,
and libraries:

4+ A master page is a preconstructed page layout that you
can use when adding pages to a multipage document.
With master pages, you can design a single “back-
ground” page and then use it as the basis for as many
document pages as you want. Without master pages,
you would have to create every page from scratch.

4+ A template is a preconstructed document that’s used to
create multiple iterations of the same design or publica-
tion. A template is a shell of a document that contains
everything in a publication —except content. Each time
you need to create a new version of a repeatedly pro-
duced publication, you open its template, add the con-
tent (text and pictures), tweak as desired, and then
print. Next issue, same thing.
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4+ As its name suggests, a library is a place where you store things. Specifically,
InDesign libraries are files for storing objects that you've created in InDesign
and that you intend to use repeatedly in multiple documents.

When you combine master pages, templates, and libraries with the ability to create
character and paragraph style sheets (covered in Chapter 20), you have a powerful
set of automation tools. Style sheets automate text formatting; libraries automate
object creation; master pages automate page construction; and templates automate
document construction.

How and to what extent you use these features depends on your personal prefer-
ences and the publications you produce. You might think that something as small
as a business card wouldn’t benefit from any of these features, but if it’s a business
card for a corporate employee, the chances are that, other than the personal infor-
mation, it’s exactly the same as business cards of every other employee. By creat-
ing and saving a business-card template, you could quickly build cards for several
or several hundred new employees. All you have to do is open the template; add
the name, title, and phone number of the new employee; and then print.

For other publications, you might use several — perhaps all — of the aforemen-
tioned timesaving features. A good newsletter template, for example, would contain
a set of style sheets for formatting text, probably a master spread or two (depend-
ing on whether all pages shared exactly the same design), and perhaps an associ-
ated library of frequently used objects —house ads, corporate logos, boilerplate
text, and so on.

Although this chapter begins with master pages, this doesn't mean that you

s should begin work on a publication by creating master pages. You may prefer to

4  work on text formatting tasks first and build style sheets before turning your atten-
tion to page-layout and document-construction tasks. One of the best things
about InDesign is that it lets you perform tasks in whatever order makes most
sense to you. Over time, you'll develop a personal modus operandi for creating
publications. Whatever style you develop, make sure that you make full use of
style sheets, libraries, master pages, and templates.

In this chapter, the terms master page and master spread are used interchange-

=~  ably. If you're working on a facing-page document, you'll use facing-page masters
that have both left- and right-hand pages. These are master spreads. For single-
sided documents, a master page has only a single page.

Creating and Applying Master Pages

Before the arrival of personal computers, publications were created by graphic
designers who leaned over light tables and — armed with matte knives and waxing
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machines — stuck galleys of type, halftones, and plastic overlays onto paste-up
boards. The paste-up boards were usually oversized sheets of white card paper on
which was printed a grid of light blue lines. The blue guidelines indicated such
things as the edge of the final, trimmed page, the margins in which text and pictures
were placed, column boundaries, and so on. These guidelines helped the designer
position elements on a page and also helped ensure consistent placement of repeat-
ing page elements, such as page numbers.

Although there are no paste-up boards in the electronic publishing world, the con-
cept has survived in the form of master pages. A master page is a nonprinting page
that you can use as the background (that is, as the starting point) for document
pages. Typically, master pages contain text and graphic elements that appear on all
pages of a publication, such as page numbers, headers, footers, folios, and so on.
And like their paste-up board ancestors, master pages also include guidelines that
indicate page edges, column boundaries, and margins, as well as other manually
created guidelines to aid page designers in placing objects. By placing items on
master pages, you save yourself the repetitive work of placing the same items one
by one on each and every document page.

By default, every InDesign document you create contains a master page. Whether
you use the master page or create and use additional master pages depends on the
kind of publication you're creating. If it’s a single-page document, such as a busi-
ness card, or an advertisement, you don’t need to worry about master pages at all.
(Generally, master pages are of little use for one-page documents.) However, if
you're creating a multipage document like a newsletter, a book, or a catalog, using
master pages will save you time and help ensure design consistency. It’s impossible
to overstate the importance of master pages. They’re one of InDesign’s most power-
ful features.

The Pages pane

When you work on multipage documents, you’ll probably want to display the Pages
pane (Window = Pages or F12), shown in Figure 7-1. The Pages pane displays an
icon-based view of document pages (bottom) and master pages (top) in the current
document. The controls in the Pages pane and its accompanying pop-up menu let
you perform several master page-related tasks, including creating and deleting
master pages, applying master pages to document pages, and creating master
pages out of document pages. The Pages pane also lets you add and remove docu-
ment pages.

\ See Chapter 5 for more information about adding and removing document pages.
ce

P
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Figure 7-1: The Pages pane. The document page icons
at the bottom of the pane show that the publication
has eight pages. The master-page icons at the top
show the default masters: None and A-Master.

Here’s a quick rundown of the controls available in the Pages pane and the com-
mands in its pop-up menu:

4+ The page icons at the top of the pane represent master pages. Every docu-

ment includes a master page called [None], which includes only margin guide-
lines, and A-Master, which reflects the margin and column settings you
specified in the New Document dialog box when you created the document. If
a letter is displayed on a master page icon, it indicates that the master spread
is based on another (parent) master page; for example, if you have a master
page named C-Master and the icons for C-Master have the letter A, then
C-Master is based on A-Master. A master page’s name is displayed below its
icon. If a master page and its name are highlighted, it means that master page
is displayed in the document window. If a master page name is displayed in
reverse type, it’s currently displayed in the document window.

4+ The page icons at the bottom of the pane represent document pages. Dog-

eared icons represent left and right pages in a facing-page document. The let-
ter displayed on a page icon indicates the master page it’s based on. (If no
letter is displayed, the page is based on the blank master page.) The numbers
below the page icons indicate the page numbers, including section number-
ing, if any (sections are covered in Chapter 5). If a page and its number are
highlighted, it means that page is currently displayed in the document win-
dow. If a page number is displayed in reverse type (that is, white characters
on a black background), it means that it’s currently displayed in the document
window.
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4 The Create New Page button (notepad icon) at the bottom of the pane lets you
add a new page with a mouse click.

4 The Delete Selected Pages button (trash can icon) lets you delete document
and master pages.

4 The Insert Pages palette menu command lets you add pages to a document
and specify the master page on which they’re based.

4 The New Master palette menu command lets you add a new master page.

4 The Duplicate Spread and Duplicate Page palette menu commands do exactly
what the names say. They let you duplicate a page or a facing-page spread.
The name of the command depends on whether a page or spread is high-
lighted in the pane.

4+ The Delete Page, Delete Spread, Delete Master Page, and Delete Master Spread
palette menu commands let you delete single pages and facing-page spreads
(both document pages and master pages). Again, the menu name will change
based on what is selected in the pane.

4 The Select Unused Masters palette menu command selects all unused master
pages and spreads, so you can easily identify and perhaps delete them.

4 The Master Options palette menu command is used for changing master-page
attributes, including name and parent master page (if you want to base a mas-
ter page on another master page).

4+ The Apply Master to Pages palette menu command is used for applying a
master-page layout to one or more document pages.

4 The Save As Master palette menu command lets you convert a document page
into a master page.

4 The Override All Master Page Items palette menu command lets you have any
local changes to the selected pages override the master-page settings. This
command moves all master items to the document page on the selected pages.

The Override All Master Pages function is new to InDesign CS.

4 The Remove All Local Overrides and the Remove Selected Local Overrides
palette menu commands returns master objects that you’ve modified on spe-
cific document pages to their original condition. If no object is selected, the
menu command is Remove All Local Overrides; if one or more objects are
selected, the menu command is Remove Selected Local Overrides.

4 The Detach Selection from Master palette menu command removes any mas-
ter page items that had been modified on the selected pages from the master
page for those selected document pages only. Essentially, this command pre-
vents you from using the Remove All Local Overrides or Remove Selected
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Local Overrides commands for these document pages, permanently changing
the master pages for them.

4+ The Keep Spread Together palette menu command ensures that the pages will
not be split apart as you add pages. Normally, adding a single page shuffles all
subsequent pages so they form new spreads. With this command, existing
spreads are maintained, so adding an odd number of pages will not cause
them to be reshuffled.

4+ The Palette Options palette menu command controls icon size, position, and
other Pages pane display settings.

4 The Numbering & Section Options palette menu command lets you establish
independently numbered sections in a single document. For example, you
could create a section if you wanted to use a different numbering scheme
(Roman numerals, perhaps) for the front matter of a book than for the body.
(See Chapter 5 for more information about sections.)

4 The Spread Flattening palette menu command lets you control image flatten-
ing for specific spreads. Flattening is InDesign’s term for reducing the resolu-
tion of graphics to save disk space and speed output time. Typically, you'd
flatten images for Web-oriented documents, since the Web displays images at
the relatively low resolution of 72 dpi. You might also flatten high-resolution
graphics when printing a draft version, to speed up printing.

\ Chapter 31 covers flattening in more detail.
ce
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Creating a new master page

If all the pages in the publication you're creating share essentially the same page
design, you don’t need to create a new master page. Instead, you can simply use the
default master page called A-Master that every document has. But if you intend to
use more than one page layout in your document — maybe you’re building a maga-
zine and you want some pages to use a three-column format and others to use a
two-column format — you’ll need to create additional master pages.

Before you create a new master page, you should have a general idea of how you
want it to look. In particular, you should know where you want to place margins,
column boundaries, and repeating elements, such as page numbers. (Laying out
master pages is covered later in this section.) When you're ready to create a new
master page, here’s what you do:

1. If the Pages pane is not displayed, choose Windows = Pages or press F12.

2. From the Pages pane’s palette menu, choose New Master.

You can also press Option+88 or Ctrl+Alt and click the Create New Page button
at the bottom of the pane. The New Master dialog box, shown in Figure 7-2, is
displayed.



Chapter 7 4+ Creating Layout Standards

New Master

prefix: Df o)
Name: Master  rm——
Based on Master: | [None] HJ

Number of Pages: 2 A

Figure 7-2: The New Master dialog box.

3. In the Prefix field, specify a one-character prefix that’s attached to the front
of the master page name and displayed on associated document page icons
in the Pages pane.

The default will be a letter, such as B, C, or D.
4. In the Name field, enter a name for the master page.

Use something descriptive, like “3-column Layout,” “Front Matter Layout,” or
“Chapter Title Pages.”

5. If you want to base the master page on another master page you’ve already
created, choose the parent master page from the Based on Master pop-up
menu.

Basing a master page on another master page is covered in more detail later
in this section.

6. In the Number of Pages field, enter the number of pages you want to
include in the master spread.

Typically, you'll enter 2 for a facing-page document and 1 for a single-page
document.

7. After you’ve finished specifying the attributes of the new master page, click
OK to close the dialog box.

After you create a new master page, it’s displayed in the document window. (When
a master page is displayed, its name is displayed in the Page Number field in the
bottom-left corner of the document window.) You can modify any of a master page’s
attributes at any time by clicking on its icon at the top of the Pages pane, choosing
Master Options from the pane’s palette menu, and then changing any of the settings
in the Master Options dialog box, which is identical to the New Master dialog box.

Basing a master page on another master page

If you find that a particular publication requires more than one master page, you
may want to first lay out a base master page (you could use the default A-Master)
and then create additional master pages that share the same basic layout but are
slightly different. For example, if the magazine you’re working on uses two-, three-,
and four-column page layouts, you could create the two-column master spread first
and include all repeating page elements. You could then create two additional
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master page spreads, base them on the two-column master, and specify different col-
umn formats. The two “children” masters would be identical to the parent except
for the number of columns. If you subsequently decide to modify, move, or delete a
repeating page element, such as the issue date in the folio, you could make the
change on the parent master and it will automatically be applied to the children
masters.

When you create a new master page, the New Master dialog box provides the
option to base it on an existing master page. You can also choose or change a mas-
ter spread’s parent by:

4+ Choosing Master Options in the Pages pane’s palette menu and then choosing
a master page from the Based on Master pop-up menu.

4 Dragging and dropping the icon of a master spread (the parent) onto the icon
of another master spread (the child). Be careful if you use this method. It’s
possible to base only one page of a master spread on another, but in most
cases you’ll want to base both pages of the child master on both pages of the
parent master. To do so, make sure that when you release the mouse button
both pages of the child are highlighted.

4 Clicking on the master spread you want to be the child, then pressing Option
or Alt and clicking on the master spread you want to be the parent.

When you base a master page on another master page, the prefix of the parent is
displayed on the page icon of the child.

If you base a master spread on another master spread, you can still modify the
s, master objects (that is, the objects inherited from the parent master) on the child
4  master page. As with regular document pages, you have to Shift+38+click or
Ctrl+Shift+click on the object inherited from a parent master to release it before
you can edit it on a child master.

QuarkXPress _ QuarkXPress cannot base a master page on another, so InDesign users who are

User

used to QuarkXPress may ignore this feature. But they shouldn’t—it has the same
power that based-on formatting provides style sheets in QuarkXPress and

= InDesign.

Creating a master spread from a document spread

Generally, if you need a new master spread, you'll begin by choosing New Master
from the Pages pane’s palette menu. But you can also create a master spread from a
spread of document pages. To do so, highlight the spread of document pages by
clicking on the page numbers below the page icons in the Pages pane, then choose
Save as Master from the Pages pane’s palette menu. The new master is assigned a
default name and prefix. If you want to modify any of its attributes, click on its
name in the Pages pane, then choose Master Options from the pop-up menu.
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Duplicating a master

You can create a copy of a master spread by clicking on its icon and then choosing
Duplicate Master Spread from the Pages pane’s palette menu or by clicking on its
icon, dragging it onto the Create new page button, and releasing the mouse. If you
duplicate a master spread, there is not a parent/child relationship between the orig-
inal master and the copy (as there is when you base a master on another master).

Deleting a master

To delete a master page, click on its name and then choose Delete Master Page from
the Pages pane’s palette menu. You can also click on the master icon, then click the
Trash icon in the Pages pane or drag the icon directly to the Trash.

Laying out a master page

Because a master page is similar to a document page, you can use the same
approach for building both master and document pages. Some designers prefer to
do a preliminary sketch on paper and then re-create the design in InDesign. You
may like to do your creative brainstorming at your computer, in which case you can
use InDesign as your sketchpad. The main difference between document pages and
master pages is that master pages don’t contain any content (other than elements
that appear on every page). So, when you’re building a master page, you should be
thinking more about the page’s overall infrastructure than about details.

Here are a few things to keep in mind when designing master pages:

4 If you’re working on a facing-page document (most multipage publications
have facing-pages), you’ll create facing-page master spreads. The left-hand
page (used for even-numbered document pages) and right-hand page (used
for odd-numbered document pages) of the master spreads you create will
be —more or less —mirror opposites of each other. For example, page num-
bers are generally placed near the outside edge of facing pages so that they’re
visible when a reader thumbs through the pages. Or you may decide to place
the publication name on one side of a spread and balance it by placing the
date of publication in the same position on the other side.

4 If you want to automatically place page numbers on document pages, you
should add a page number character on each page of your master spreads.
To add a page number character, draw a text frame with the Type tool, then
choose Type > Insert Special Character => Auto Page Number or press
Option+8+N or Ctrl+Alt+N. The prefix of the master page (A, B, C, and so on)
is displayed on the master page, but on document pages, the actual page num-
ber is used. When you add a page number to a master page, make sure to for-
mat it as you want the actual page numbers to look on document pages.

177
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4 Perhaps the most important elements of a master page are the margins and

column guides. To specify margins and columns for a master page, make sure
the page is displayed in the document window, then choose Layout => Margins
and Columns. The Margins and Columns dialog box, shown in Figure 7-3, is dis-
played. The controls in this dialog box let you specify the position of the mar-
gins, the number of columns, and the gutter width (space between columns).

Margins and Columns
Margins G oK 3
Top: =~ 6p0 Inside: (73 ¢
P e | (el )
Bottom: —={3pd Qutside: (=]350
E Preview
Columns
Number: =3 Gutter: == 1p0

Figure 7-3: The Margins and Columns dialog box.

When placing text elements on master pages, you may want to use placeholder
text instead of actual text. For example, if you produce a monthly magazine and
you want to include the name of the month on each spread (perhaps opposite the
name of the newsletter on the facing page), you could use placeholder text like
“IName of month]” or “[Add month here]” If you use placeholder text, format it as
you want the actual text to look on document pages. Of course, be sure to replace
the placeholder text with the actual text in your final document.

4 If you want to place additional guidelines on a master page, you can add as

many custom guidelines as you want. (Guidelines are covered later in this
chapter.)

4+ Like objects on document pages, the objects you place on master pages have

a stacking order. On document pages, all master objects remain beneath any
objects you add to the page.

Figure 7-4 shows a typical master page spread for a newsletter. Whenever you want
to make a change to a master page, double-click on its icon in the Pages pane to dis-
play it in the document window.

Tip
7
Tip
7
QuarkXPress _
User

To copy a master page from one document to another, display the source docu-
ment, click on the master's name in the Pages pane, drag it to the window of the
target document, and then release the mouse button.

The ability to move master pages from one document to another, or even from
one layout to another in a QuarkXPress 6 project, does not exist in QuarkXPress.
So QuarkXPress users may be in the habit of using libraries to transfer master-page
items from one document to another. In InDesign, you don't need to take this cir-
cuitous route.
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Figure 7-4: A typical three-column master layout for a newsletter. The footer at the
bottom of the left- and right-hand pages includes a page-number character (B) on
the outside.

Applying a master page to document pages

After you’ve built a master page, you can apply it to new document pages as you
add them or to existing pages. (See Chapter 5 for information about adding and
removing document pages.) For facing-page documents, you can apply both pages
of a master spread to both pages of a document spread, or you can apply one

page of a master spread to one page of a document spread. For example, you could
apply a master page with a two-column format to the left-hand page of a document
spread and apply a master page with a three-column format to the right-hand page.

To apply only one page of a master spread to a document page, click on the icon of
the master spread and then drag it onto the icon of the document page you want to
format. When the target document page is highlighted (framed in a black rectangle,
as shown in the left side of Figure 7-5), release the mouse button. If both document
pages are highlighted, both sides of the master spread are applied to the document
spread.

To apply both pages of a master spread to both pages of a document spread, drag
the master spread’s icon onto the document spread’s page numbers (under its page
icon). When both pages of the target document spread are highlighted, as shown in
the right side of Figure 7-5, release the mouse button.
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Figure 7-5: Left: Applying a single page of
a master spread to a document page. Right:
Applying both pages of a master spread to
a document spread.

InDesign also lets you apply a master page to multiple document pages in a single
operation. You can

4 Select the document pages to which you want to apply a master. You can
click on a page then Shift+click on another page to select a range of pages, or
you can hold down the 8 or Ctrl keys and click on pages to select nonconsec-
utive pages. After you've selected the document pages, press Option or Alt
and click on the master page you want to apply.

4+ Choose Apply Master to Pages from the Pages pane’s palette menu. The
Apply Master dialog box, shown in Figure 7-6, is displayed. Choose the master
page you want to apply from the Apply Master pop-up menu and specify the
pages to which you want to apply it in the To Pages field. Use commas to sep-
arate page numbers; use a hyphen to specify a range of pages. For example,
you could enter 2, 4-6, 8 to apply the selected master to pages 2, 4, 5, 6, and 8.

Apply Master
Apply Master: | A-Master | :! hﬁl(—"
LY
To Pages: 7 Cancel

Figure 7-6: The Apply Master dialog box.

You can also use these techniques to apply a different master page to a document
page. If you want to disassociate a document page from its applied master page,
you can apply the default None master page the same way you apply any other
master page.
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Modifying master items on document pages

As you work on a document page that’s based on a master, you may find that you
need to modify, move, or delete a master object. For example, you might apply a
master to the first page of a newsletter and then decide that the page number
you've placed on the master page isn’t necessary for page 1. In this case, you'd
select the master object on the document page and delete it. Any change you make
to a master object on a local page is referred to as a local override.

If you remove a master object from a document page, you sever the object’s rela-
tionship to the master-page object for that document page only. If you subsequently
move or modify the object on the master page, it won't affect the deleted object on
the document page —it remains deleted on that particular document page.

However, you can modify a master object on a document page without completely
breaking its relationship to the corresponding object on the master page. For exam-
ple, if you change the size, position, or content of a master object on a document
page, any subsequent size, position, or content change you make to the object on
the master page does not affect the object you modified. But any changes you make
to the stroke or fill of the object on the master page are applied to the overridden
master object on the document page. Similarly, if you use any of the transformation
tools or the corresponding controls in the Transform pane to modify a master
object on a document page, any similar transformations applied to the correspond-
ing object on the master page are not applied to the overridden object.

In other words, any type of attribute applied to the item on a particular document
page prevents any changes to the same attribute on the master page from affecting
that document page.

The Display Master Items command (View <> Display Master Items) lets you show
s or hide master objects on document pages. When a checkmark is displayed next
#  to the name of the command, master objects are displayed.

To modify a master object on a document page, you must select it. However, master
objects behave slightly differently than other objects on document pages.
Specifically, to select a master object on a document page, you must hold down
Shift+88 or Ctrl+Shift when you click on the object with one of the selection tools.
After you select a master object on a document page, you can modify it in the same
manner as you modify non-master objects.

If you modify one or more master objects on a document page and then decide
you want to revert back to using the original master objects, you can remove the
local overrides. To do so, display the document page that contains the master
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objects you've modified, select the objects, and then choose Remove Selected
Local Overrides from the Pages pane’s palette menu. If no objects are selected, the
command name changes to Remove All Local Overrides (if the selected spread
doesn’t have any modified master objects, the command is not available).

Using Templates

A template is a preconstructed InDesign document that you use as the starting
point for creating multiple versions of the same design or publication. For example,
if you were assigned the task of creating ten testimonial ads that share the same
layout but use different pictures and text, you would begin by creating a template
that contains all the elements that are the same in every ad — placeholder frames
for the pictures and text, guidelines, and so on. Along the same lines, if you produce
periodicals like a newsletter or a magazine, you should create a template for

each one.

The process of creating a template is much the same as creating a document. You
create the required character and paragraph style sheets, master pages, repeating
elements (for example, the nameplate on the first page and mailing information on
the back page), and so on. The only thing you don’t add to a template is actual
content.

It would be nice if designers had the luxury of creating a template for each new
publication they produced. But in the real world, templates are often created by
gutting an existing document. The first time you create a publication such as a
newsletter, the main goal during production is getting a finished document to the
printer — hopefully on time. After you’ve finished the first issue of a publication
(or a prototype), you can open the file, remove all objects and content that aren’t
repeated in every issue, and then save the gutted file as a template. This is proba-
bly how you’ll wind up building many of your templates.

Here are the steps in creating a template:
1. Choose File~> Save As or press Shift+3+S or Ctrl+Shift+S to display the Save
As dialog box, shown in Figure 7-7.
2. Choose a storage folder and specify a name for the file.

It’s not a bad idea to add “Template” to the filename, if possible. It lets who-
ever uses the file know its purpose.

3. On a Mac, choose InDesign 3.0 Template in the Format pop-up menu. On a
PC, choose InDesign 3.0 Template from the Save As Type pop-up menu.

4. Click OK to close the Save As dialog box and save the template.
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Tip If you're designing a template that will be used by others, you might want to add
a layer of instructions. When it's time to print a document based on the template,
simply hide the annotation layer. (See Chapter 6 for more information about
working with layers.)

\.u""

Save As

Save As: |Data Sheets Template.ind

Format:  InDesign 3.0 template 'ﬂ

Where: | [ Data Sheets 3] B —

_,;‘ Customer CGuide P = 95000976_...5 1-gg.indd
Data Sheets » % 95000976_...LP_DS_l.indd m
Revisions f...LP Removal F % 95000976_... DS l.indd.1

Sales Presentation P -] 95000976 _...LP_DS_1.pdf

Web pages P = 95000977_...5_1-gg.indd [

% 95000977_...LP_DS_l.indd |*
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L3 € Cancel )
[ Cancel E

-~
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Save astype: | InDesign 3.0template [v] [ canca |

Figure 7-7: Saving templates is slightly different on a
Mac (top) from saving templates in Windows (bottom).

A template is almost exactly the same as a standard InDesign document with one
major exception: A template is slightly protected from being overridden. When you
open a template, it’s assigned a default name (Untitled-1, Untitled-2, and so on). The
first time you choose File ©> Save, or press 88+S or Ctrl+S, the Save As dialog box is
displayed.

/Note As you use a template over time, you're likely to discover that you forgot to include
' something — perhaps a style sheet, a repeating element on a particular master
page, or an entire master page. To modify a template, you must open it, make your
changes, and then use the Save or Save As command to save the file in the same
place and with the same name as the original.
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Storing Objects in Libraries

If you're a savvy InDesign user, you’ll never build the same document twice. After
all, that’s what templates are for. Along the same lines, you never have to create the
same object twice; that’s what libraries are for. An InDesign library is a file — similar
in some ways to a document file—in which you can store individual objects,
groups and nested objects, ruler guides, and grids (ruler guides and grids are cov-
ered in the next section). For example, if you've created a logo in InDesign and you
want to use it in other documents, you could place it in a library. Once you've
saved an object in a library, it’s as though you have an endless supply of copies.
Every time you need a copy, all you have to do is drag one out of the library.

Creating a library is easy: Choose File> New => Library, choose a location to save
the library in, give the library a name, and click OK. Figure 7-8 shows the dialog box.

[F covt brochure
Honesty Program
[F Manuf brochure

New Library
Save As: Tables.indl
where: | [~ A00 B E] R —
" AOO Py [0 Customer Guide [
| ADO Govt P ¥ Data Sheets P
Banking brochure I [7 Revisions f _LP Removal |
7 FAQs P [7 sales Presentation P
Fin brochure . [7 web pages ’
.
J
.

New Folder Add to Favorites
[N [ Cancel )}

Figure 7-8: The dialog box in which you save a
new library.

You can create as many libraries as you want and store them wherever is most con-
venient, including on a networked server so other InDesign users can share them.
When it comes to naming and organizing libraries, the choice is yours. If you work
for an advertising agency, for example, you may decide to create a separate library
for each client; each library could contain logos, images, boilerplate text (dis-
claimers, copyright information, legal blurbs), and so on. If you work for an in-
house art department, you could create separate libraries for corporate logos
(black-and-white, grayscale, and two-color/four-color variations), house ads, fre-
quently used pictures, and standing art.
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InDesign libraries are cross-platform. That is, you can open libraries created on a
5, Mac using a PC and vice versa. On the PC, libraries have the filename extension
# indl, while on the Mac they don't have to have a filename extension. In a cross-
platform environment, add the PC filename extensions even to Mac files so
Windows InDesign will recognize the file as a library.

After you create a new library, an empty library pane is displayed, as shown in
Figure 7-9. The name you assigned is displayed in its title bar. You add items by
dragging them to the pane. You can group the pane with other panes (by dragging
its tab onto another pane) or close it by clicking its close box or choosing Close
Library from its pop-up menu.

1
Tables Close Library

Add All Items on Page

OofOshown | [ VI | 3 |%

Library Item Information

Show Library Subset

List View

. « Thumbnail View
New Library Item

Sort ltems >

Delete Library Item

Figure 7-9: A new (empty) library and its
accompanying pop-up menu.

At this point, you're ready to begin placing objects into the library, after which, you
can begin copying the objects into other documents. Before we look at moving
items into and out of libraries, here’s a brief description of the controls in a library
pane and the commands in the accompanying pop-up menu (refer to Figure 7-9):

4 The numbers in the lower-left corner of the pane indicate the number of
objects currently displayed in the pane (though not necessarily visible
depending on the size of the pane) and the number of objects in the library.
Search capabilities let you display a subset of the entire library.

4 Clicking the Library Item Information button displays the Item Information
dialog box, shown in Figure 7-10. Here you can assign a name, type, and
description to a library object. (You can search for library objects based on
these attributes.)

4 The Show Library Subset button displays a dialog box that lets you locate and
display objects that meet certain search criteria.
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/ Note
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Creation Date: 4/25/03 3:29 PM

Description:

Figure 7-10: The Item Information dialog box.

4+The New Library Item lets you add a selected object on a document page to
a library.

4 The Delete Library Item button lets you delete highlighted objects in the
library.

4 The Close Library palette menu command does the same thing as clicking
a library pane’s close box.

If a library pane is part of another palette, if it is the frontmost palette, and if you
close that palette, the library pane is closed as well. But if the library pane is not
the frontmost pane in the palette, the library remains open when you close the
palette.

4 The Add Item and Add All [tems on Page commands let you add a selected
item or all items on a document page to a library. You can also simply drag
items into the pane.

4 The Place Item(s) command lets you place copies of selected library objects
into a document.

4 The Delete Item(s) command lets you remove selected library objects from
the library.

4 The Item Information command displays the Item Information dialog box
(refer to Figure 7-10).

4 The Show Subset command opens the same dialog box that’s displayed if you
click the Show Library Subset button. The dialog box lets you locate and dis-
play objects that meet certain search criteria.

4 The Show All command displays all library objects (rather than a subset iden-
tified by a previous search).

4+ When the List View option is checked, library objects are displayed in a list
rather than as Thumbnails.
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4+ When the Thumbnails View option is checked, each library object is displayed
in its own thumbnail window.

4 The Sort Items command lets you sort library items by name, type, and date.
To open an existing library, choose File > Open or press 8+0 or Ctrl+O.

Multiple users can share a library, but only if it's locked (meaning people can use

=~ items in the library but not add new ones). To lock a library on the Mac, locate the
library file in the Finder, select it, choose File=> Get Info, and select the Locked
option. In Windows, locate the library file in its current folder, right-click the file-
name or icon, then select Read-Only from the Properties contextual menu’s
General pane.

To delete a library, you must delete the file. Either drag the file icon to the Trash
(Mac) or move the file icon to the Recycle Bin (Windows).

Adding and deleting library objects

In addition to placing individual objects, such as text and graphics frames, into a
library, you can also place multiple-selected objects, groups, nested frames, ruler
guides, guidelines, and all objects on a page.

There are several ways to add objects to a library. You can

4 Select one or more objects and then drag and drop them into an open
library pane.

4 Select one or more objects and then click the New Library Item button at the
bottom of an open library pane.

4 Select one or more objects and then choose Add Item from the pop-up menu
of an open library pane.

4 Choose Add All Items on Page from the pop-up menu of an open library pane
to add all objects on the current page or spread.

If you hold down the Option or Alt key when adding an object to a library using
s any of the preceding methods, the Item Information dialog box is displayed. This
#  dialog box lets you add searchable attributes to the object.

To delete a library object, drag its icon to the Trash icon at the bottom of the pane
or click on the object once and then choose Delete Item(s) from the library pane’s
palette menu. You can select a range of objects by clicking on the first one and then
Shift+clicking on the last one. You can select multiple, noncontinuous objects by
holding down the 8 or Ctrl key and clicking on their icon.

187
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Library caveats

Because the attributes of the original object are retained when you place a copy in a library,
there are some pitfalls you have to watch out for:

4+ If you move, modify, or delete the original graphic files associated with a pic-
ture you've placed in a library and then copy the library object into a docu-
ment, the Links pane will report that the graphics file is modified or missing
(just as it would if you imported the picture then moved, modified, or deleted
the original). It's a good idea to store graphics files used in libraries in a common
location, such as in a Standards folder on the network, so the graphics files aren't
accidentally moved or deleted when you delete or archive a set of project files that
happen to contain objects placed in libraries.

4 If you copy a text frame from a library onto a document page, any character
style sheets, paragraph style sheets, or colors in the library object that have
the same name as character style sheets, paragraph style sheets, or colors in
the target document are replaced by those in the target document. If the target
document does not contain character style sheets, paragraph style sheets, or colors
in the placed text, they're added to the document.

4+ If you copy a text frame from a library onto a document page, make sure that
the fonts are available. If they're not available, you'll have to choose alternate
fonts.

When you place an object into a library, all its attributes are saved. For example, if
you import a picture into a document and then place a copy of the picture into a
library, the path to the original picture file is saved, as are any transformations
you've applied to the picture or its frame (scale, rotation, shear, and so on). If you
save text in a library, all formats, including style sheets, are retained.

Cataloging library objects

If your libraries contain only a few objects, finding the one you’re looking for won’t
be very hard. But a library can hold as many objects as you want, and as a library
becomes bigger, locating a particular object gets increasingly difficult. To make
library objects easier to find, InDesign lets you tag them with several searchable
attributes.

To tag a library element, select it and then choose Item Information from the library
pane’s palette menu. You can also display the Item Information dialog box by dou-
ble-clicking on a library object or by clicking once on a library object and then
clicking the Library Item Information icon at the bottom of the library pane. (Figure
7-10 shows the Item Information dialog box.) Now specify a Name, Object Type,
and/or Description. In the Description field, it’s a good idea to enter one or more
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keywords that describe the object so that you can easily find it later. Click OK to
close the dialog box and return to the document.

InDesign lets you search for library objects based on the information specified in
the Item Information dialog box. For example, if you’'ve placed several different cor-
porate logos into a library that includes many other objects, you could search for
the term logo in the Name or Description field. If you used the word logo in either of
these fields for your logos, a search of these fields for the word logo will identify
and display your logos. The ability to search for library objects based on name and
description is a good reason to name your library objects carefully and consistently
and to specify keywords in the Description field of the Item Information dialog box.
Follow these steps:

1. Choose Show Subset from a library pane’s palette menu or click on the
Show Library Subset icon at the bottom of the pane.

The Subset dialog box, shown in Figure 7-11, is displayed.

Subset

@ Search Entire Library E
() search Currently Shown Items F—————
. Cancel
Parameters
" ltem Name %) [ contains 9 LR Back
: Forward
T — c ¥ =
More Choices Fewer Choices

Figure 7-11: The Subset dialog box.

2. To search the entire library, click Search Entire Library; to search only the
objects currently displayed in the page, click Search Currently Shown
Items.

3. From the leftmost pop-up menu in the Parameters area, choose the Item
Information category you want to search: ltem Name, Creation Date, Object
Type, or Description.

4. From the next pop-up menu choose Contains if you intend to search for text
contained in the chosen category; choose Doesn’t Contain if you want to
exclude objects that contain the text you specify.

5. In the rightmost field, type the word or phrase you want to search for (if
Contains is selected) or exclude (if Doesn’t Contain is selected).

6. To add more search criteria, click More Choices; to reduce the number of
search criteria, click Fewer Choices.

You can add up to five levels of search criteria.
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Tip

Tip

7. To display objects that match all search criteria, select Match All; to display
objects that match any of the search criteria, select Match Any One.

These options are available only if two or more levels of search criteria are
displayed.

8. Click OK to conduct the search and close the dialog box.

All the objects that match the search criteria are displayed in the pane. The pane is
empty if no objects matched the search criteria. If you want to display all objects
after conducting a search, choose Show All from the library pane’s palette menu.

The Sort Items command in a library pane’s palette menu lets you sort objects by
. Name, Oldest, Newest, and Type. If you sort by Oldest or Newest, items are
#  arranged based on the order in which they were placed into the library.

Copying library objects onto document pages

Once you’ve placed an object into a library and, optionally, specified item informa-
tion for the object, you can place copies of the library object into any document or
into another library. To place a copy of a library object onto the currently displayed
document page, click on the object’s icon in the library pane and drag it onto the
page. As you drag, the outline of the library object is displayed. Release the mouse
button when the outline is positioned where you want to place the object. You can
also place a library object onto a document by clicking on its icon and then choos-
ing Place Item(s).

You can copy an object from one library to another by dragging its icon from the
.. source library pane and dropping it onto the target library pane. If you hold down
#  the Option or Alt key when dragging and dropping an object between libraries, the
original object is removed from the source library (in effect moving it from one
library to the other).

Using Ruler Guides and Grids

If you've every seen a carpenter use a chalked string to “snap” a temporary line to
use as an aid for aligning objects, you understand the concept behind guidelines.
They’re not structurally necessary and they don’t show in the final product, yet
they can still make your work easier. InDesign lets you create and display three
types of nonprinting guidelines:

4 Ruler guides are moveable guidelines that you can create by hand or automati-
cally. They’re helpful for placing items precisely and aligning multiple items.
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4 A baseline grid is a series of horizontal lines that help in aligning lines of text
and objects across a multicolumn page. When displayed, a baseline grid
makes a page look like a sheet of lined paper.

4+ A document grid is a crisscross of horizontal and vertical lines that aid in
object alignment and placement.

InDesign’s grids and guides capabilities verge on overkill. Chances are you’ll end up
using a combination of ruler guides and the baseline or ruler guides and the docu-
ment grid, but using all three is more complicated than necessary.

Ruler guides

InDesign lets you create individual ruler guides manually or a set of ruler guides
automatically with the Create Guides command (Layout => Create Guides).

Creating ruler guides manually

To create manual ruler guides, go to the page or spread onto which you want to
place ruler guides. (If the rulers are not displayed at the top and left of the docu-
ment window, choose View > Show Rulers or press 38+R or Ctrl+R.) Now click on
the horizontal ruler or vertical ruler, and drag the pointer onto a page or the paste-
board. Release the mouse button when the guideline is positioned where you want
it. If you release the mouse when the pointer is over a page, the ruler guide extends
from one edge of the page to the other (but not across a spread). If you release the
mouse button when the pointer is over the pasteboard, the ruler guide extends
across both pages of a spread and the pasteboard. If you want a guide to extend
across a spread and the pasteboard, you can also hold down the 38 or Ctrl key as
you drag and release the mouse when the pointer is over a page.

Tip You can place both a horizontal and vertical guide at the same time by pressing 38
s, or Ctrl and dragging the ruler intersection point onto a page.
V]
Ruler guides are cyan in color (unless you change the color using Layout > Ruler
Guides) and are associated with the layer onto which they’re placed. You can show
and hide ruler guides by showing and hiding the layers that contain them. You can
even create layers that contain nothing but ruler guides and then show and hide
them as you wish. (See Chapter 6 for more information about layers.)

Tip You can also place a guide that extends across the page or spread and pasteboard
s, by double-clicking on the vertical or horizontal ruler.
V]

Tip If you want to create ruler guides for several document pages, create a master

s page, add the guides to the master page, and then apply the master to the appro-
#  priate document pages.
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Creating a set of guides automatically
Follow these steps to create a set of ruler guides:

- Cross-
Reference

P

1.

2.

If the documents contains multiple layers, display the Layers pane
(Window ~> Layers or F7) and click the name of the layer to which you want
to add guides.

See Chapter 6 for more information about layers.

Choose Layout = Create Guides.

The Create Guides dialog box, shown in Figure 7-12, is displayed. Check
Preview if you want to see the guides on the current document page as you
create them.
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Figure 7-12: The Create Guides dialog box, along with
the guides it created.

. In the Rows and Columns areas specify the number of guides you want to

add in the Number fields and, optionally, specify a Gutter width between
horizontal (Rows) and vertical (Columns) guides.

Enter 0 in the Gutter fields if you don’t want gutters between guides.

. In the Options area, click Margins to fit the guides in the margin bound-

aries; click Page to fit the guides within the page boundary.
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5. Check Remove Existing Ruler Guides to remove any previously placed
ruler guides.

6. When you’re done specifying the attributes of the ruler guides, click OK to
close the dialog box.

Working with ruler guides

Once you’ve created ruler guides, you can show or hide them, lock or unlock them,
and select and move, copy and paste, or delete one or more guides at a time. Here
are a few pointers for working with ruler guides:

4+ To display or hide ruler guides, choose View => Show/Hide Guides or press 88+;
(semicolon) or Ctrl+; (semicolon).

4 To lock or unlock all ruler guides, choose View > Lock Guides or press
Option+8+; (semicolon) or Ctrl+Alt+; (semicolon). (If Lock Guides is checked,
ruler guides are locked.)

4+ To select a ruler guide, click on it with a selection tool. To select multiple
guides, hold down the Shift key and click on them. The color of a selected
guide changes from blue to the color of its layer. To select all ruler guides on a
page or spread, press Option+8+G or Ctrl+Alt+G.

4+ To move a guide, click and drag it as you would any object. To move multiple
guides, select them and then drag them. To move guides to another page,
select them, choose Edit => Cut, or $8+X or Ctrl+X, or Edit = Copy, or 8+C or
Ctrl+C, display the target page, then choose Edit=> Paste, or 8+V or Ctrl+V. If
the target page is the same shape as the source page, the guides are placed in
their original position.

4+ To delete ruler guides, select them and then press Delete or Backspace.

4+ To change the color of the ruler guides and the view percentage above which
they’re displayed (the default view threshold is 5 percent), choose Layout >
Ruler Guides. The Ruler Guides dialog box, shown in Figure 7-13, is displayed.
Modify the View Threshold value and choose a different color from the Color
pop-up menu, and then click OK. If you change the settings in the Ruler
Guides dialog box when no documents are open, the new settings become
defaults and are applied to all subsequently created documents.

Ruler Guides

View Threshold: 5% 3 r
Color: [ OCyan ) cancel )

Figure 7-13: The Ruler Guides dialog box.
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4+ To display ruler guides behind objects instead of in front, choose InDesign &>
Preferences = Guides & Pasteboard on the Mac or Edit => Preferences > Guides
& Pasteboard in Windows, or press 8+K or Ctrl+K, and check Guides in Back

in the Guide Options section of the dialog box.

4 If the Snap to Guides command (View = Snap to Guides, or Shift+88+; [semi-
colon] or Ctrl+Shift+; [semicolon]) is checked, objects edges will snap to
ruler guides when you drag them in the snap zone. To specify the snap zone
(the distance —in pixels — at which an object will snap to a guide), choose
InDesign = Preferences => Guides & Pasteboard on the Mac or Edit =
Preferences > Guides & Pasteboard in Windows, or press 88+K or Ctrl+K, and
enter a value in the Snap to Zone field in the Guide Options section of the dia-

log box.

Working with the baseline grid

Every new document you create includes a baseline grid. If the document you're
working on uses a multicolumn page layout, a baseline grid can be helpful for align-
ing text baselines across columns and for ensuring that object edges align with text
baselines. Baseline grids aren’t much use for small documents — business cards,
ads, and so on—and one-column designs. Here’s how to create them:

1. Choose InDesign => Preferences - Grids on the Mac or Edit = Preferences~
Grids in Windows, or press 38+K or Ctrl+K and choose the Grids pane.

The Grids pane, shown in Figure 7-14, is displayed.
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Figure 7-14: The Grids pane of the Preferences dialog box.
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2. Choose a color from the Color pop-up menu in the Baseline Grid area.

3. In the Start field, enter the distance between the top of the page and the
first grid line.

If you enter 0, the Increment Every value determines the distance between the
top of the page and the first grid line.

4. Enter the distance between grid lines in the Increment Every field.

Generally, the value you enter in this field will be the same as the leading
value you use for the publication’s body text.

5. Choose a View Threshold percentage from the pop-up menu or enter a
value in the field.

Generally, you don’t want to display the baseline grid at reduced view per-
centages because grid lines become tightly spaced.

6. Click OK to close the dialog box and return to the document.

A baseline grid is document-wide (that is, you can’t change it from page to page),
and grid lines are displayed behind all objects, layers, and ruler guides. The default
baseline grid begins a ¥ inch from the top of a document page, the grid lines are
light blue lines and placed 1 pica apart; and grid lines are displayed at view percent-
ages above 75 percent. If you change any of these settings when no documents are
open, the changes are applied to all subsequently created documents; if a docu-
ment is open, changes apply only to that document.

Tip The Show/Hide Baseline Grid command (View+> Show/Hide Baseline Grid, or
s, Option+38+' [apostrophe] or Ctrl+Alt+' [apostrophe]) lets you display and hide a
4  document’s baseline grid.

Working with the document grid

Like the baseline grid, every document includes a default document grid, which is a
set of horizontal and vertical lines. And like baseline grids, you may or may not find
the document grid to be a useful aid for laying out pages. If you like working on
graph paper in the real world, the document guide may be just your cup of tea. On
the other hand, you may find document grids to be too constricting and opt not to
use them. If you want to use document grids, follow these steps:

1. Choose InDesign => Preferences => Grids on the Mac or Edit=> Preferences=>
Grids in Windows, or press 8+K or Ctrl+K.
The Grids pane displays (refer to Figure 7-14).

2. Choose a color from the Color pop-up menu in the Document Grid area.

3. Enter the distance between grid lines in the Gridline Every field.

If your basic measurement unit is an inch, you’ll probably want to use the
default value of 1 inch.
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4. Enter the number of divisions between grid lines in the Subdivisions field.

If your basic measurement unit is an inch, you can specify a value of 6 to sub-
divide the grid into 1-pica squares. Or, if you prefer, you can enter a value of 4,
8, 16, and so on to subdivide the grid into standard divisions of an inch.

5. Click OK to close the dialog box and return to the document.

Tip The Show/Hide Document Grid command (View => Show/Hide Document Grid or
s~ 3+' [apostrophe] or Ctrl+' [apostrophe]) lets you display and hide the document

V] id

grid.

Summary

If you want to be a true InDesign expert, you must take advantage of three of its
most powerful features: master pages, templates, and libraries. All these features
save time and ensure design consistency across documents. A master page is a pre-
formatted page design that you can apply to document pages in a multipage publi-
cation; a template is a preconstructed document that serves as the starting point
when you need to create multiple versions of the same publication; and a library is
a storage file in which you can save any object you've created with InDesign for use
in other publications.

To help you place and align objects, InDesign lets you create three types of guide-
lines: ruler guides, the baseline grid, and the document grid. You can show or hide
guidelines, and you have the option to snap object edges to guidelines when you
drag them in the specified snap zone.

+ 0+ 0+



