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Chapter 
Thirteen

Type

Look in this chapter to find answers to questions on:

• Creating & Editing

• Committing Type

• Display Issues

• Filters

• Font Issues

• Moving

• Paragraph Type

• Platforms/Versions

• Rasterizing

• Transforming

• Type Mask
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Creating & Editing

 Q Is it possible to change the attributes of several 
Type layers at once? I have several separate Type 
layers but would like to change the font of all of 
them at once. Can I do this?

a  Just press Command (PC: Control) and click  
on the Type layers’ names in the Layers palette 
to select them. Then, change the attributes 
in the Character or Paragraph palettes (both 
found under the Window menu) or within the 
Options Bar.

 Q I need to change the color of my type, but it’s 
hard to see because it is highlighted.

a  To change the text color, you probably high-
lighted the text and changed the color. The 
problem is that you can’t see the new color, so 
press Command-H (PC: Control-H) to temporar-
ily hide the highlight, and then change your 
color in the Options Bar.

 Q Is there a quick way to color my text? To change 
the color of my text, do I have to use the Options 
Bar, or is there a quicker way?

a  You can change the color of a Type layer with-
out highlighting it. Just make sure your Type 
layer is the active layer, then choose your color 
by clicking on the Foreground color swatch and 
pressing Option-Delete (PC: Alt-Backspace). 
(Again, you don’t have to have the type high-
lighted, just make sure the layer is active.)

 Q Is it possible to change the font and size without 
selecting the text? I want to change the font or 
size of some existing type. Do I have to switch 
to the Type tool, highlight the text, and then 
change the settings?

a  First make sure the Type layer is the active layer. 
Then, as long as you can see the Character pal-
ette, you can change any setting in the dialog. 
(The same goes for the Paragraph palette, and 
they’re both under the Window menu.) The 
only time you need to use the Type tool (T) is  
to edit the actual content (spelling, etc.).

 Q Is there a quick way to change the space between 
two letters? I’d like to adjust the spacing between 
two characters in a word. How do I do that?

a  With the Type tool (T) selected, click your cur-
sor between two characters in your text. Then 
hold down Option (PC: Alt) and press the Left 
Arrow key to decrease the space or the Right 
Arrow key to increase the space. (This function 
is called “kerning.”)

 QWhat are leading, tracking, and kerning?

a  Kerning refers to altering the space between 
two letters. Leading refers to the space between  
lines of type. Tracking refers to the space  
between all characters in the type.

 Q Is it possible to create type in inches instead 
of points? For my project it would be easier to 
create my type size in inches rather than points. 
Can I do that?

a  Yes, when you enter a size (in the Options Bar 
or the Character palette), just type “in” after 
the size. This will size the type in inches. Note: 
As soon as you press Return (PC: Enter), the 
measurement will revert to the equivalent in 
points of the size you entered in inches, saving 
you the math.
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 Q Is there a quick way to increase the font size of 
my type? I want to be able to quickly increase 
or decrease the font size to see how it looks. Is 
there a quick way to do this?

a  Select your text with the Type tool (T), and then 
click in the Font Size field in the Options Bar. 
Use the Up or Down Arrow keys to change the 
size by 1 point, or use Shift and the Arrow keys 
to change the size by 10-point increments. Or if 
you prefer keyboard shortcuts, press Command-
Shift-. (Period key) (PC: Control-Shift-.) to make 
the text larger or Command-Shift-, (Comma key) 
(PC: Control-Shift-,) to make it smaller.

 Q Is there a quick way to highlight my type?
I was using another tool and wanted to  
highlight and edit my type. Is there an easier 
way than choosing the Type tool and then 
highlighting the text on my image?

a  Yes, with any tool, double-click on the “T” 
symbol in the thumbnail to the left of the layer 
name. Photoshop will automatically switch to 
the Type tool and highlight your type. Note: 
This works particularly well when you have a 
number of Type layers and you want to make 
sure you are highlighting the correct text.

 Q Is it possible to change type from horizontal  
to vertical?

a  Yes, Control-click (PC: Right-click) on the type 
with the Type tool (T) and choose the appropri-
ate orientation from the contextual menu. Or, 
make your Type layer the target layer and from 
the Layer menu choose Type>Vertical.

 Q I entered a bunch of type with the Caps Lock key 
on by mistake. Is there a simple way to change it 
to lowercase?

a  Sure, there’s a couple of options: Highlight 
the text with the Type tool (T) and open the 
Character palette (you can press Command-T 
[PC: Control-T] to open the palette, as long 
as you’ve already highlighted the text). From 
the Character palette’s flyout menu, deselect 
All Caps. Or, if you like keyboard shortcuts, 
highlight the text and press Command-Shift-K 
(PC: Control-Shift-K). This shortcut works as a 
“toggle switch”—it turns All Caps into lower-
case or lowercase into All Caps. (Make sure you 
have the text highlighted first, as the same 
shortcut is used for Color Settings.)

 Q This has never happened before, but now when 
I enter some type I can only see the first line of 
type—the rest is missing in action. Why is that?

a  There are two factors that are causing this 
to happen. First, Photoshop remembers the 
last settings you have used—sometimes well 
past the point of being helpful. In this case 
Photoshop is “helping” by remembering the 
leading (space between lines) that you previ-
ously used—even after you changed the font 
size. Also, unlike some programs, if you change 
the font size, the leading does not automati-
cally change. For example, say you have used a 
size of 300 points and leading of 315 points. If 
you change the font size to 40, Photoshop still 
remembers the leading of 315, and because 
it doesn’t automatically change, it will stay as 
is. So, your second line of type is there, it’s just 
really far down in the document! To fix this, use 
the Paragraph palette (Windows>Paragraph) 
to lower the leading to a more reasonable 
amount. From then on, just remember to check 
the leading (and tracking and kerning and 
horizontal scaling…) each time you change the 
size of your type.



›  ›  PHOTOSHOP CS2    H ELP  D ES K  BOOK

151

continued

 Q How do I create an outline of text, in other 
words, no fill, just a stroke? But here’s the catch, I 
want to be able to edit the type…

a  There are a couple of options: add a new layer 
with a stroke or use the Stroke layer style. 
They each have their advantages, so we’ll 
look at both. Here’s how to add a separate 
layer with a stroke: Click on the Create a New 
Layer icon in the Layers palette to add a new 
layer above the Type layer. Then hold down 
Command (PC: Control) and click on the 
Type layer’s thumbnail to create a selection. 
From the Edit menu, choose Stroke. Set the 
Width and Color of the stroke and click OK. To 
“remove” the fill in the type, click on the Type 
layer and change the Opacity in the Layers 
palette from 100% to 0%. Because the stroke 
is on a separate layer, you can add effects to 
it, such as a beveled edge. On the other hand, 
if you decide to edit the text, you have to 
delete the stroke layer and start over.

Alternately, you can use a layer style. With the 
Type layer selected, choose Stroke in the Add 
a Layer Style pop-up menu at the bottom of 
the Layers palette. Select the Size and Color 
of the stroke and click OK. You will see the 
original filled text with a stroke around it.  
As before, click on the Type layer and lower 
the Opacity to 0%. The biggest advantage 
of this method is that the stroke is a “live” 
effect, so when you edit the type, the stroke 
changes automatically. (Another advantage 
of using the layer style is the option to stroke 
with not only a solid color, but also a pattern 
or a gradient.)

Committing Type

 Q Is there a quick way to finish with the Type tool 
other than clicking the Commit button? When 
I’ve finished typing, I need to click the Commit 
button in the Options Bar to finish with the Type 
tool. Is there a quicker way?

a  Press the Enter key on your numeric keypad or 
click on another tool in the Toolbox.

 Q How do I commit my type on a laptop? In order 
to tell the Type tool I’m finished, I have to com-
mit it by clicking the Commit button. I read that 
you can also use the Enter key, but my laptop 
doesn’t have a keypad. Am I out of luck?

a  No, you can use another shortcut, made for 
anyone lacking an Enter keypad key. Just press 
Command-Return (PC: Control-Enter) instead.

 Q I’m trying to use Command-Return  
(PC: Control-Enter) to commit my type,  
but it’s not working. Why?

a  Check to see if your cursor is still flashing in  
one of the text fields (Size, for example) in the 
Options Bar or any open palette. If it is, you’ll 
need to press Return (PC: Enter) to finalize the 
choice in that field, then press Command- 
Return (PC: Control-Enter) to commit the type.

Display Issues

 Q Is it possible to avoid jagged text when import-
ing? Is there way to import text from other 
programs into Photoshop without getting 
jagged edges?

a  When you import text from elsewhere using 
the File>Place command, it has to be converted 
into pixels—there’s no way around that. That 
means that imported type is not really type 
at all—it is a pixel layer that will likely appear 
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more jagged than type added directly in Photo
shop. Instead, copy the text from the other 
application, click once with the Type tool (T), 
and paste (Edit>Paste) your copied text.

 Q Why does my text look jagged? When I save 
as a JPEG, my text looks more jagged than in 
Photoshop format (PSD). Why?

a  When you save in formats like TIFF or JPEG, 
the Type layers are converted to pixels. To help 
avoid jagged edges in your text, be sure None 
is not selected in the Anti-aliasing pop-up 
menu in the Options Bar (when you have the 
Type tool [T] active).

 Q Why doesn’t my text look like vector type? I 
thought type was now vector in Photoshop, but 
it sure doesn’t look like it when I put my TIFF file 
into my page-layout software. What gives?

a  While you’re working in Photoshop, the type is 
vector. As soon as you save in a raster format, 
such as BMP, JPEG, or TIFF, the type becomes 
rasterized and the quality “suffers.” The only way 
to preserve the vector quality is to save in PSD 
or PDF format.

Filters

 Q How do I fill type with a texture? I have a Type 
layer and I’d like it to look textured. Can I add  
a texture without losing the option of editing 
my text?

a  One option is to add a layer style—Pattern 
Overlay. From the Layer menu, select Layer 
Style>Pattern Overlay. You can use existing 
patterns or create your own. This method 
works well because it is a layer style that can 
easily be changed. Another option is to click 
on the Create a New Layer icon to add a new 

layer above the Type 
layer and fill it with 
whatever texture 
you want (try going 
to the Swatches or 
Styles palettes in the 
Window menu). Then 
use Layer>Create 
Clipping Mask to 
create a layer clipping 
mask that will make 
the texture visible 
only in the letters. 
This method has 
several advantages: 
You can still edit the 
type, the texture can 
be moved around in the letters, and the texture 
is not restricted to being a repeating pattern 
(you can add some filters, etc.).

 QWhy can’t I blur my Type layer?

a  You cannot have any kind of filter or paint ap-
plied to a Type layer while it’s a Type layer. To 
give yourself increased flexibility, duplicate the 
Type layer (Command-J [PC: Control-J]). Then, 
in the Layer menu select Rasterize>Type. Now 
that the layer has been rasterized (turned into 
pixels), you should be able to run your blur fil-
ter. (You do not have to duplicate the Type layer 
first, but once a Type layer is rasterized, there’s 
no going back to edit the type.) Note: If you still 
can’t blur the text, check to see if Lock Transpar-
ent Pixels is selected in the Layers palette.

 QWhy can’t I paint on (apply a filter to) my type?

a  By nature, Type layers are locked so that you 
cannot use painting tools or filters. To get 
around this you must:

1. �Rasterize the Type layer (or better still,  
make a copy and then rasterize it [see  
previous question]).
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2. �Click on the Create a New Layer icon to add 
a separate layer immediately above the Type 
layer on which you paint (filter) and then go 
to Layer>Create Clipping Mask. By painting 
in the mask, it will create the appearance of 
the type being painted, but offers the advan-
tage of keeping an editable Type layer.

Font Issues

 QHow do I get a trademark or copyright symbol?

a  The answer lies in your operating system, 
because these text functions are not controlled 
by Photoshop. Depending on your platform, 
you either press keyboard combinations or go 
to a “font map” that will help you create the 
character. The bottom line is that the process is 
the same for any application.

Mac: 
Copyright (©): Option-G
Trademark (™): Option-2

PC: 
Copyright (©): Alt-0169  
(using the numeric keypad)
Trademark (™): Alt-0153  
(using the numeric keypad)

 Q How do I get fonts to show in Photoshop?  
I want to have Chinese fonts in my artwork.  
How do I get these fonts to work in Photoshop?

a  Fonts are an operating system issue. If the fonts 
are installed on your computer, they should 
show up in all your software. 

 QWhat is Faux Bold (Faux Italic)?

a  Faux Bold is an option that lets you add “pre-
tend bold” to a font that does not have a bold 
version. It is found in the Character palette’s 

flyout menu. Note: Some functions, such as Text 
Warp and embedding fonts in PDF files, do not 
work if Faux Bold (or Italic) is used.

 Q Is there a quick way to scroll through fonts? I’ve 
highlighted my type and want to experiment 
with different fonts.

a  As long as your text is highlighted with the Type 
tool (T), go to the Options Bar, highlight the 
font name in the Font field, and use the Up or 
Down Arrow keys on your keyboard to scroll 
through the fonts. Note: You do not have to 
highlight the text with the Type tool for this to 
work—you can also use the Character palette 
(Window>Character).

 Q Is it possible to change my default font?  
Whenever I click with my Type tool, I get  
whatever font and size I previously used.  
Can I change to a standard choice or default?

a  You can create the equivalent of a default with 
a tool preset. Change to the font and size you 
want, and then from the Tool Presets palette 
(which you open by clicking on the tool thumb-
nail on the left side of the Options Bar), click on 
the Create New Tool Preset icon. When using 
the Type tool (T), you can turn on the Current 
Tool Only checkbox to see your tool presets 
for the Type tool only. Choose the appropriate 
“default” and away you go!
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Moving

 QHow do I center type on an image?

a  Command-click (PC: Control-click) to select the 
Background layer and your Type layer. From the 
Layer menu choose Align and pick the align-
ment you want (or choose the Move tool [V] 
and use the Align icons in the Options Bar). You 
can also use Smart Guides (View>Show>Smart 
Guides) to center your text. As you move your 
Type layer, a smart guide will appear when the 
type is centered.

 Q How can I move type while I’m typing? Is it pos-
sible to reposition my type without committing 
it first?

a  All you have to do is drag the cursor about an 
inch away from the type and your cursor will 
temporarily change into the Move tool.

 Q Why can’t I use the Move tool with vertical  
type? When I use my Type tool, I can move my 
mouse away from the type to temporarily  
get the Move tool to position the type. I can’t 
seem to get this to work with vertical type.  
Am I missing something?

a  It should work, but if it doesn’t, you can also 
try holding down Command (PC: Control) to 
temporarily activate the Move tool while using 
the Type tool.

Paragraph Type

 Q Is it possible to convert from regular text to 
paragraph text? I’ve created regular text but 
now would like it to be in a paragraph box. Do I 
have to start over, or can I convert the text?

a  With the Type tool (T), Control-click (PC: Right-
click) and choose Convert to Paragraph Text in 
the contextual menu. Or go to the Layer menu 
and choose Type>Convert to Paragraph Text.

 Q Is it possible to create a paragraph text box in 
a specific size? When I click-and-drag with my 
Type tool to create a paragraph text box, I’d like 
to make it a specific size. Can I?

a  The manual method would be to watch the 
Info palette as you drag with the Type tool (T). 
Another method would be to hold down  
Option (PC: Alt) and click on the image where 
you want the top-left corner of your paragraph 
box. A dialog will appear in which you can en-
ter the specific dimensions. Note: It may default 
to points, but you can use any unit of measure-
ment simply by typing— for example, “2.5 in”  
to use inches rather than points. 
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 Q How do I convert paragraph type to regular 
(point) type?

a  From the Layer menu, select Type>Convert 
to Point Text, or with the Type tool (T) active 
Control-click (PC: Right-click) on the Type layer’s 
name and choose Convert to Point Text in the 
contextual menu. 

Platforms/Versions

 Q 
Is it possible to give a layered document to 
someone if they don’t have my fonts?

a  Yes. The type will still show up, but they will 
not be able to edit it. If they attempt to edit the 
type, Photoshop will tell them that the font is 
not installed and must be replaced. To avoid 
this, rasterize the type (Layer>Rasterize>Type) 
before sending the file (but keep a copy with 
the original Type layers for yourself!).

 QWhat is the best way to deal with type from older 
versions of Photoshop? When I open a docu-
ment that I created in an earlier version, I get a 
message about updating Type layers. Should I 
update or not?

a  That depends on whether you want to edit 
the Type layers or not. If you don’t click the 
Update button in the warning dialog, you 
will see your Type layer when the document 
opens; but before you are able to edit it, you’ll 
have to update the text anyway. Don’t worry 
about updating the layer(s) as you open the 
document, because as soon as you double-
click on the Type layer to edit it, Photoshop 
will do the updating for you. Note: When you 
update the type, the look of the type might 
change slightly.

Rasterizing

 Q What is rasterizing?

a  Rasterizing really means “to turn into pixels.” 
Type layers and Shape layers both use  
vectors to describe their contents, meaning 
you get high quality and scalability. Raster 
layers are those containing pixels (which are 
not as scalable). Rasterizing is the process  
of converting vectors to raster layers made  
of pixels.

 Q When should I rasterize a Type layer?

a  Many functions can be completed without 
rasterizing type, such as color, layer effects, 
clipping masks, and some transformations.  
If you can complete the operation without  
rasterizing, do it! If the “cancel” symbol  
appears as your cursor, that tells you the  
operation cannot be done to a Type layer—
you must rasterize the layer. I suggest that 
you duplicate the Type layer (Command-J 
[PC: Control-J]) and then rasterize the copy. 
That way, you still have a Type layer you can 
edit should you need to. To rasterize a Type 
layer, go to the Layer menu and choose 
Rasterize>Type. Or Control-click (PC: Right-
click) on the layer’s name in the Layers palette 
and choose Rasterize Type from the contex-
tual menu.
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 Q Is there a quick way to rasterize type?

a  Sure, instead of going to the Layer menu, you 
can also Control-click (PC: Right-click) on the 
layer’s name and choose Rasterize Type from 
the contextual menu.

Transforming

 Q Is it possible to change the shape of letters? Is 
there a way to alter the actual shape of letters 
like you can in vector software?

a  Yes, by converting the type to a path or a shape. 
From the Layer menu choose Type>Create 
Work Path or Convert to Shape. Then you can 
use the Pen tool (P) to add/delete anchor 
points and the Direct Selection tool to reshape 
the paths. Note: You cannot use this command 
if your typeface uses Faux Bold or Faux Italic.

 Q Is it possible to distort my type but still keep it 
editable? I want to use transformations on a 
Type layer but would still like to edit my text.  
Is that possible?

a  It depends on the transformation you want 
to use. Many transformations—Scale, Rotate, 
Skew, and Flip found under Edit>Transform—
can be applied to Type layers without losing 
the ability to edit the type. Other transforma-
tions such as Distort and Perspective will not 
work unless you first rasterize the Type layer 
(Layer>Type>Rasterize).

 QIs it possible to convert a Type layer into paths?

AYes. From the Layer menu choose Type>Create 
Work Path. Then you can use the Pen tool (P) to 
add/delete anchor points and the Direct Selec-
tion tool to reshape the paths. Note: You cannot 
use this command if your typeface uses Faux 
Bold or Faux Italic.

 Q How can I put text on a curve? I can’t figure out 
how to take a straight line of text and curve it so 
that it makes a perfect circle. 

a  First, use the Ellipse tool (Shift-U) to draw a 
circular path (be sure the Paths icon is selected 
in the tool’s Options Bar). Then select your type 
with the Type tool (T), cut it (Edit>Cut), click on 
the circular path with the Type tool, and paste 
(Edit>Paste). To reposition the type along the 
path, hold down Command (PC: Control) and 
drag the cursor along the path.

 Q How do I hide part of a Type layer? I want to hide 
part of a Type layer to make it look like the type 
is behind part of an image. How do I do that 
without losing the ability to edit the text?

a  First, click on the Add Layer Mask icon at the 
bottom of the Layers palette to add a layer 
mask to the Type layer. Then, with black as your 
Foreground color, paint (on the mask) using 
the Brush tool (B) over the portions of the Type 
layer that you want to hide.
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 Q Why can’t I add a perspective distort to my 
type? I am trying to use the Edit>Transform 
commands on a Type layer and most of them 
are available, but not Distort or Perspective. Is it 
possible to do a perspective distort to type?

a  Not really—at least it’s not possible to use Dis-
tort or Perspective and still keep editable type. 
You’ll have to do one of the following:

1. �Rasterize the Type layer (Layer>Rasterize> 
Type) before applying Distort or Perspective 
(or even better, make a copy of the Type layer 
and then rasterize the copy).

2. �Change the Type layer to a Shape layer. From 
the Layer menu, choose Type>Convert to 
Shape. Now you can use Distort or Perspec-
tive and have the added advantage of using 
a vector shape to describe the type. It’s still 
not editable, but at least it will have higher 
quality edges.

Type Mask

 Q What is the Type Mask tool?

a  This tool lets you create a selection based on 
text. When you are finished typing, you will 
have a selection rather than a Type layer. Note: 
A new layer is not automatically created with 
this tool.

 Q Is it possible to edit the font and size after you’ve 
used the Type Mask tool?

a  No, you cannot edit the font, because the Type 
Mask tool creates a selection. As an alternate 
plan, you could create a regular Type layer 
using the regular Type tool (T), and then Com-
mand-click (PC: Control-click) on the Type 
layer’s thumbnail to load it as a selection. That 
way, you can edit the Type layer and then cre-
ate a new selection based on that edited text.

 Q Why doesn’t the Type Mask tool create a  
new layer? When I used the Type Mask tool,  
I assumed it would make a new layer like the 
Type tool, but it doesn’t. Why not?

a  Frankly, I can’t tell you why, but I can confirm 
that, yes, you need to click on the Create a New 
Layer icon at the bottom of the Layers palette 
first if you want that type-based selection to be 
on its own layer.


