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Become an expert in 
InDesign image forensics

By Keith Gilbert

The scene: You’ve inherited a complicated InDesign 
file from a coworker, and you’re burning the midnight 
oil making layout changes. Wait a minute! One of 
the images doesn’t look right; you suspect it’s been 
stretched. And what’s this? The mole is on the wrong 
side of a person’s face! Has the image been reflected? 
And where did the images on pages 6 through 16 
come from? Do you have legal rights to use them? 

Answering these and other burning questions 
takes some detective work, but I’ll show you how to 
sift through the scene of the crimes using forensic 
techniques in InDesign CS3 and CS4.

CSI: 
Creative 

Suite
Investigation
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Figure 1.  When chosen with the Selection 
tool, the image doesn’t appear to be stretched 

(top). Using the Selection tool shows you the 
truth (middle), and lets you make both values 

equal (bottom).

Has the Image Been Stretched?
The dastardly villain pictured in Figure 1 appears to be 
stretched horizontally. Yet, when you select the image 
with the Selection tool (black arrow), the Scale fields in 
the Control panel show that the image is 100% in both 
X (width) and Y (height). What’s going on?

Images always display as 100% in the Control panel 
when selected with the Selection tool. But when you 
select the image with the Direct Selection tool (white 
arrow), you’ll see the true scaling of the image. In this 
case, the image is scaled to 36% in width and to 47% in 
height. To return the image to its original proportions, 
enter equal values in both scale fields. 

To catch non-proportional scaling as soon as it 
happens, use the Live Preflight feature of InDesign 
CS4. Just add the “Non-Proportional Scaling of Placed 
Object” condition to your Preflight Profile in the 
Preflight panel (Window > Output > Preflight). 
For more information about how to use the Preflight 
feature of CS4, see the October/November 2008 issue 
(#26) of InDesign Magazine.
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$100 Discount
when you register one week in advance of the start date

 

ROCKY MOUNTAIN 

TRAINING
Visit www.rockymountaintraining.com or 

call 303-319-9817 to register. Space is limited.

Attend live, interactive training 
on the Adobe Creative Suite applications

in a virtual classroom led by a Top 5 Adobe Certi�ed
Instructor—all from the comfort of your home or o�ce.

Receive all the interaction of a traditional classroom virtually:
• view the instructor’s screen

• share your screen with fellow classmates
• ask questions and receive instant feedback  

Get top-notch Adobe
training from the 

experts...in your PJs!

A�ordable. Virtual. Versatile.A�ordable. Virtual. Versatile.

About our Instructors

All of the Rocky Mountain Training instructors 
have current Adobe Certi�ed Instructor status. Three have 

been recognized by Adobe Systems, Inc. as among the 
Top Five Most Highly-Rated Adobe Certi�ed Instructors, Worldwide.
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Figure 3. An 
image that has 
been flipped 
horizontally or 
vertically will be 
recognizable by 
the inverted  
“P” symbol in the 
Control panel.

Figure 4. The InDesign CS4 File Information dialog box.
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Has the Image Been Cropped?
There are several easy ways to tell if an image has 
been cropped in InDesign. One way is to select the 
image with the Selection (black arrow) tool, and note 
the location of the edges of the frame. Then triple 
click on the image to switch to the Direct Selection 
(white arrow) tool and select the contents of the 
frame, and look at the position of the bounding box. 
If these two boxes are different, then the image has 
been cropped in InDesign (Figure 2). 

Another way to quickly tell if an image is cropped 
in InDesign is to double-click on one of the corner 
handles of the frame with the Selection tool. If the 
image has been cropped, it will immediately be 
uncropped. You can then return to the way it was with 
Edit > Undo. 

Here’s a third way: click and hold down the Direct 
Select (white arrow) tool on the image; after about 
one second, any cropped area will appear “ghosted” 
back outside the graphic frame.

Has the Image Been Flipped?
In the past, editors and fact checkers couldn’t tell 
for sure if an image was flipped after it was placed 
in InDesign. Back to our scary felon in Figure 3. Is 
the mole supposed to be under his right eye or 
his left eye? Prior to InDesign CS3, an image that 
was flipped in InDesign would display as having a 
rotation angle of 180o, which is incorrect. Finally 
in CS3, Adobe got it right. Now, an image that has 
been flipped will display a reverse “P” symbol in the 
Control panel when the image is selected with either 
of the selection tools. Alas, if the image was flipped 
in Photoshop, saved, and then placed in InDesign, 
there’s no trail of evidence left behind.

Copyright, Location, and More
Depending on where your image came from, you 
may have access to all sorts of rich metadata (data 
about data) associated with the image. This metadata 
could reveal useful information about the image, such 
as a caption, the geographic location, or copyright 
and usage information. Select an image in InDesign 
and choose File Info from the Info panel menu, or 
choose Utilities > XMP File Info (CS4) or Link File 
Info (CS3) from the Info panel menu. The dialog box 
in Figure 4 will appear. In CS3 the dialog box has the 
same information but is laid out differently. 

With InDesign CS3 you can copy information from 
the File Info dialog and paste it in your layout. This is 
used in some publishing workflows to pass caption 
information between photographers or photo editors 
and designers. Unfortunately, in CS4 the information 
in the File Info dialog is read-only unless you use a 
script, such as the LabelGraphics script inside the 
Samples folder in the Scripts folder. (See page 40 for 
more on this script.)

Figure 2. If an image has been cropped, the graphic frame (top) will 
be different than the image bounding box (bottom).
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Will the Image Print with High Quality?
The Info panel also helps in determining whether a 
selected graphic is vector (made up of mathematical 
curves) or raster (made up of pixels). Whenever you 
see a number next to the Effective PPI field in the Info 
panel, you can be sure that the image is raster. In this 
case, consult with your print vendor to determine if 
the Effective PPI of your images is sufficient for your 
type of output. 

If no number is displayed, the image is probably 
vector and can be scaled to any size you need. An 
exception would be a Photoshop EPS file, or when a 
raster image is used in a vector drawing program like 
Illustrator. In these cases, just make sure that View 
> Display Performance > High Quality Display is 
chosen, and then zoom way, way in on the image. A 
vector image will always display smoothly, since vector 
images are resolution-independent. A raster image will 

eventually begin to display large pixels if you zoom in 
far enough, as shown in Figure 5. 

Is the Correct Color Being Used?
Let’s say you have a client that uses a very specific 
bright orange, PANTONE 1595, as their corporate 
color. But they don’t always print with spot color, so 
they have an alternate version of their logo using a 
specific CMYK mixture to achieve the best orange 
they can get. Their logo appears in your project, and 
you want to double check that indeed, the spot color 
version of the logo is what is being used. Just choose 
Window > Output > Separations Preview, select 

Figure 5. The fingerprint on the left is a raster image, the fingerprint 
on the right is a vector image.

Figure 6. The Separations Preview panel is an easy way to check 
the exact color used in an image, regardless of whether it is spot or 
process color.

Did you know that you can “extract” an image that 
has been embedded in an InDesign file? Even if the 
original image was a CMYK PSD file with multiple 
layers that was placed in InDesign and then cropped, 
rotated and scaled, the original uncropped, layered, 
unscaled image can be retrieved from the InDesign 
file. How? Simply right-click on the image in the 
Links panel and choose Unembed Link. You will see 
a confusing dialog box on the screen asking you if 
you want to “link to the original files”. Just choose “No” 
(which seems wrong) and click the OK button, choose 
a location for the file, and it will be extracted from the 
InDesign file in all its original glory.

How to extract embedded images

Separations from the View drop down list, and point 
at the orange part of the logo with your mouse. The 
actual ink that will be used to output that part of 
the logo appears as percentages in your separations 
preview panel (Figure 6).
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Has the Image Been Recolored?
Look at Figure 7 and you’ll see something strange. The 
Info panel says that the color space of the image is 
Grayscale, yet the image is clearly in color. What unsolved 
mystery do we have here? InDesign allows you to apply 
color to grayscale TIFF, JPEG, BMP or PSD images, and 
that is what has been done here. On an image like this, 
if you select the frame with the Selection tool and look 
at the Swatches panel, you’ll see the color of the frame 
(in this case yellow) highlighted. When you switch to the 
Direct Selection tool and select the contents of the frame 
you will discover that the content of the frame has been 
colored also (blue in this case). Mystery solved!

What Kind of Image Is It?
The Info panel or the Links panel is the quickest way 
to tell if the image is a TIFF, JPEG, PSD, AI, EPS, etc. 
If you see PDF displayed in the panel, you might be 
confused. PDF will appear for both placed PDF files 
and for placed AI (Adobe Illustrator) files. See Figure 8.
Even though you might be accustomed to placing 
AI files directly into InDesign (and, by the way, there 
are numerous advantages to this over using EPS 
files), InDesign technically can’t import AI files, it only 
can import PDF files. When you save an AI file out of 
Illustrator, you see the box displayed in Figure 9. 

You must check the “Create PDF Compatible 
File” option. InDesign then sees the file as a PDF and 
displays that in the Info panel. This is one example of 
why it’s important to always use filename extensions 
such as .PDF or .AI to help distinguish one file type 
from another. Otherwise, there’s no way to tell whether 
a linked image in InDesign is a generic placed PDF file, 
or an editable AI file.

Where Does the Image Reside?
You might wonder where on your vast corporate 
network a particular imported image resides. One way 

Figure 8. The small icon to 
the right of the image name 
indicates the image has been 
embedded, and is no longer 
linked to the original graphic.

Figure 9. When artwork is saved in Illustrator in AI format, the  
Create PDF Compatible File option must be checked in order for the 
image to be placed in InDesign. InDesign will recognize the file as a 
PDF file.

Figure 7. A placed grayscale image, colorized in InDesign. Adobe PDF 
will display in the Info panel for both placed AI files and placed PDF 
files. When artwork is saved in Illustrator in AI format, the Create PDF 
Compatible File option must be checked in order for the image to be 
placed in InDesign. InDesign will recognize the file as a PDF file.

to find out is to select the image, right-click or ctrl-click 
on it, and then choose Graphics > Reveal in Finder 
(Mac) or Graphics > Reveal in Explorer (Windows). 
This will open a Finder or Explorer window and bring 
you right to the image. Or, you can right-click/Ctrl-click 
on the image name in the Links panel and choose 
Reveal in Finder/Reveal in Explorer. You may also hover 
over the name of the linked graphic in the Links panel, 
and after a brief pause you’ll see the full path to the 
image displayed in a pale yellow tool tip. 

You may run across images where the Reveal in 
Finder/Explorer option doesn’t appear in the menu. In 
this case, one of two things is going on: The image is 
either embedded or it has been pasted into InDesign. 
Look closely at the Links panel in these cases. If the 
image is embedded, you’ll see a small icon to the right 
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of the image as shown in Figure 10. If you don’t see 
anything listed in the links panel, the graphic has been 
pasted into InDesign from another program, which 
is never a good practice. There is no way to get at the 
original graphic in this case.

Does the Image have Additional Layers, 
Clipping Paths, or Channels?
Placed PSD, AI, PDF, and INDD files may contain 
multiple layers, all of which may not be visible in 
InDesign. To see if the image has additional layers, 
select the image, right-click/Ctrl-click on the image, 
and choose Object Layer Options. If the image 
contains additional layers, a dialog will appear that will 
let you manipulate the layer visibility. A single image 
can appear in multiple places in your layout, each time 
with a different set of layers displayed!

A raster EPS, PSD, or TIFF file may contain paths 
that can help you mask an image or apply a varnish 
to part of an image. To see if the image contains any 
paths, select the image and choose Object > Clipping 
Path > Options. Choose Photoshop Path for the type, 
and then use the drop down next to Path to choose 
the path you want. If Photoshop Path is grayed out, the 
image doesn’t contain any paths.

Extra channels may have been built and saved with 
the image to allow the image to be masked. If so, you 
can build a clipping path from one of these channels, 
or for higher-quality results, go to Photoshop and 
turn the channel into a layer mask. To see if the image 
contains any extra channels, select the image and 
choose Object > Clipping Path > Options, and choose 

Alpha Channel for the Type. This is just for seeing if an 
alpha channel is in there—I don’t recommend actually 
using the alpha channel as a clipping path, so click 
Cancel to leave this dialog box.

You’re a CSI: Creative Suite Investigator
Now that you’ve learned these image forensic 
techniques, you can solve any difficult image situation. 
Hopefully, images used in your layouts will be less 
mysterious, and any image crimes committed in 
layouts you encounter will be easily solved.

Keith Gilbert� is a design-industry consultant and educator 
with clients such as Apple, Adobe, Best Buy, Cargill, General 
Mills, Lands’ End, Medtronic, Target, and the United Nations. 
His work has taken him throughout the world. He is an 
Adobe Certified Instructor in InDesign, InCopy, Illustrator, 
Photoshop, and Acrobat, and is the Chapter Representative 
for the Minneapolis InDesign User Group. Visit his Tips & 
Techniques blog at blog.gilbertconsulting.com.

Figure 10. The small icon to 
the right of the image name 
indicates the image has been 
embedded, and is no longer 
linked to the original graphic.

Manage text changes in InDesign and InCopy

CtrlChanges is a plug-in for Adobe InDesign and Adobe 
InCopy users that require a clear and accurate solution to 
a common problem, to visually be able to see what has 
been changed in the InDesign document. 

With CtrlChanges you don’t need to spend valuable time trying 
to find what has been changed or not. CtrlChanges track all text 
changes in a document as it is being revised, and display added 
or deleted text in the Layout view. CtrlChanges is available for 
both Adobe InDesign and Adobe InCopy, so if you are looking for 
a smart and “easy to use” solution, CtrlChanges will give you and 
your workgroup new exciting possibilities.

For more information. please visit www.ctrl-ps.com 
Ctrl Publishing develops and markets systems designed to improve your creation process
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