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Make your layouts 

fly through the air 

with the greatest of ease.

Interactive 
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What To Expect In a Nutshell
When you create a new InDesign document, 
you now have the choice of two Intents: Web 
or Print. (“Web” is a bit misleading—think 

“on-screen documents,” since files with a “Web” 
intent are definitely not limited to the Web.) 
Once you’ve chosen the Web intent, you can 
select from a range of screen-appropriate 
page sizes (800 × 600, 1024 × 768, etc.). The 
document’s measurement system will auto-
matically be set to pixels, all swatches will be 
RGB (even black), and the Transparency Blend 
Space is set to RGB. After you click OK, you 
can animate page objects, add Flash-based 
play controllers to videos, create slide shows 
within a page, and control page transitions 
without writing a single line of code (whee!). 

When you’re done, you can export your file 
to SWF (Shockwave Flash), FLA (editable 
Flash format), or interactive PDF. However, 
the interactive PDF format doesn’t support 
animated page objects, so SWF is clearly the 
most fun. Figure 1 is a simple SWF animation 
I created in InDesign. 

You can also use InDesign and other Adobe 
software to create iPad apps. For details, see 

“From InDesign to iPad” on page 18.

What’s New?
Here’s a quick way to get an idea of the 
new interactive wonders awaiting you: Just 
choose the new Interactive workspace (Win-
dow > Workspace > Interactive, or select 

Interactive from the Workspace pull-down 
menu in the Control panel) to view the per-
tinent panels. While the Buttons panel isn’t 
new, note the new arrivals.

if you’ve longed to have flying text in your page layouts, your dream has come true: 
indesign Cs5 now offers interactive features that previously were available only to those 
willing to plumb the depths of Flash Professional. indesign’s tools are flexible, powerful, 
and intuitive—you don’t have to learn a new application to join the ranks of interactive 
designers. While some functions still require Flash Professional (such as interactive forms), 
you may be surprised how much you can accomplish with just the tools in indesign.

Interactive InDesign

Figure 1: I created this simple SWF animation in InDesign. 

http://indesignmag.com/_System/_AdvancedStore/qryProductDetail.asp/Id/G777-F192168013176-N572-E20101029080154
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Animation Panel
The Animation panel (Window > Interac-
tive > Animation) is a great playground: You 
can start with one of the motion presets 
and modify it. Choose a motion preset for a 
selected object, and our old friend the 
InDesign butterfly previews the results. I rec-
ommend that you crank up InDesign right 
now, select any object on your page, open 
the Animation panel (Figure 2), and try every 
option.  Here’s a breakdown of the major 
controls in the Animation panel:
 ❱ Object Name: Since you may wish to 

use a button to trigger an animation, it 
behooves you to give the object a name 
you’ll remember, either here in the Anima-
tion panel, or in the swell revamped Lay-
ers panel.

 ❱ Motion Presets: With a single click, you 
can make an object fly in from above 
the page, gallop in place—even go up 
in smoke. If the extensive list of motion 
presets isn’t enough, you can modify an 
existing preset to create your own, and 

Figure 2: Get to know the Animation panel.

Publish the 
“World Over” with

 Publish up to 140 Languages 
in InDesign CS5

 Support of Middle Eastern 
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 Support of Indic and Asian 
Languages
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http://in-tools.com/worldtoolspluscs5_im.html


I N D E S I G N  M A G A Z I N E  38 October | November 2010 10

Interactive InDesign

import presets that were created in Flash 
Professional. Many of the motion presets 
use motion paths to define the movement 
of an object in the animation, and you can 
edit the motion paths that guide the ani-
mations with the Pen tool. See the Figure 3 
movie for an example.  

 ❱ Event Trigger: If you’re not planning to 
use a button to trigger the animation, you 
can choose from On Page Load, On Page 
Click, On Click (Self ), On Roll Over (Self ). 
The “Self” refers to clicking on or rolling 
over the object itself.

 ❱ Play and Speed Controls: You can control 
the duration of the animation (how long 
an object takes to fly in, for example), and 
how many times the animation should play. 
You can modify the speed to ease in (start 
slow, finish fast), ease out (start fast, finish 
slow), or ease in and out. You can also set 
the animation to loop endlessly (shudder).

 ❱ Properties: Click the triangle next to the 
Properties label to see even more options 
for the current motion preset. You can 
choose whether the animation starts at 
the object’s current appearance or finishes 
with the current appearance. If the docu-
ment will be used for both print and SWF 
export, choosing “To Current Appearance” 
ensures that the object will appear in the 
page when in its static state. You can add 
a rotation to the animation (set the value 
to more than 360° to induce more than 
one complete rotation), and the object can 
shrink or grow over the duration of the 
animation. You can even make the object 
fade in or out. See the Figure 4 movie for 
an example. 

An added plus: All motion paths are edit-
able, so you can modify the animations cre-
ated by presets that use motion paths, such 
as “Fly In From Right.” You can select a motion 
path with the Direct Selection tool—it’s just a 
Bézier line! Once it’s selected, you can stretch 
it or move any of its points to get just the 
motion you want. Or use the Pen tool to add 
or modify points on the curve. When you’re 
done, the Preset pop-up menu lists the ani-
mation as “Custom.” If you want to save the 
preset to use again, just choose “Save” from 
the Animation panel menu and give the 
new preset a name. Want to share with a 

Figure 4: Think of the potential for sensory overload!

Figure 3: Motion presets in action!
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friend? Choose Manage Presets from the 
Animation Panel menu, select a custom 

preset, and click the Save As button. 
You can even create your own motion 

paths: Draw a curving path with the Pen 
or Pencil tool, then Shift-click to select the 

object you want to animate. (It’s best if the 
object is positioned near the starting point 
of the path.) When both are selected, click 
the Convert to Motion Path icon ( ) at the 
bottom of the Animation panel, and click the 
Preview icon.

Timing
If you have more than one animation event 
(and that includes videos, which I’ll discuss 
below) in a spread, you should use the Tim-
ing panel (Window > Interactive > Timing) 
to control the play order; that is, which ani-
mation should play when. You can do this 
by dragging entries up and down in the list. 
InDesign CS5 treats each spread as a separate 
entity when it comes to controlling anima-
tion: When you view the Timing panel, you 
only see the events in the spread you’re cur-
rently viewing (Figure 5). 

You can select an animation and add a 
delay—helpful when you want multiple ani-
mations to finish at the same instant but start 

Figure 5: The Timing panel controls the play order of  
animations and multimedia content.

The New Preview Panel 
You don’t have to export your work to SWF or interactive PDF to test it: The new Preview 
panel renders your animation right in InDesign so you can check your progress. It’s avail-
able through Window > Interactive > Preview, or by clicking the Preview icon at the bottom 
of the Animation, Timing, or Buttons panels. You can preview the interactive features on 
the current spread in their full glory, or choose the Preview Document Mode ( ) to test in-
teractivity across the full document. (There’s also an option, available in the Preview panel 
menu, to test in a browser, if you like.) 

Tip 1: The Preview panel is resizable. Make 

it big enough that you can comfortably view 

animations in detail. Collapse it to button 

mode to get it out of the way when you don’t 

need it; it will appear in expanded mode 

when triggered.

Tip 2: To see examples of a bunch of differ-

ent animations and interactive elements, 

choose Window > Utilities > Scripts. Open

the Application > JavaScript folder in the 

Scripts panel. Then double-click the script 

called AnimationEncyclopedia.jsx. InDesign 

generates a six-page document with all the 

animation possibilities. Save this file for fu-

ture reference; you can deconstruct the ani-

mated objects to learn what makes them tick. 

When you’re done, export as SWF or use the 

Preview panel to view all the goodies!
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at different times, or when you want an 
animation to wait a moment to play after a 

page turn. 
You can link two or more animations so 

they play together. Otherwise, the second 
event won’t start until the first event is fin-
ished. See Figure 6, a movie, for an example.

Multimedia Content
In previous versions of InDesign, you could 
add four movie formats to an InDesign docu-
ment: QuickTime (.mov), AVI, MPEG, and SWF 
formats. Now the acronyms have changed: 

It’s recommended that you use Flash Video 
formats (.FLV, .F4V), H.264-encoded files 
(such as MP4), and SWF. If you’re planning on 
exporting only to interactive PDF, you can 
still import QuickTime and MPEG files. But 
even if you’re headed to PDF, you’ll be better 
served by using the more modern formats, to 
take advantage of the media support built 
into Acrobat 9 and Adobe Reader 9.

You can place a video file like any other 
asset (File > Place, or drag and drop), but 
to control it once it’s inside your document, 
you’ll need the Media panel (Window > 
Interactive > Media). Use the Media panel 
to preview video and placed animations 
(Figure 7). 

You can also choose to trigger the media 
upon page load (if you haven’t rigged up a 
button to do the job in the Buttons panel; 
see “Buttons,” below). You can set the video 
to loop (this only works for SWF export), and 
you can select a poster to represent the video 
in the page—either from a frame of the 
video, a preset filmstrip icon, or a separate 
image (you can also set the poster option 
to “None,” which makes the video invisible 

until it’s triggered). Choose from a long list 
of Flash-based play controllers, which offer 
play, stop, pause, and volume controls. The 
options available in the Media panel depend 
on whether you’ve selected an animation, a 
sound, or a movie. 

You can also use the “Video from URL” 
option available in the Media panel menu, 

Place Video From URL

Place Video or Audio File
Set options for PDF export

Play on Page Load
Loop Control

Choose Poster
Controller

Navigation Points

Preview

Play Movie Preview

Add/Remove
Navigational Points

Figure 7: Video controls in the Media panel.

Figure 6: You can link two or more animations so they play to-
gether. Otherwise, the second event won’t start until the first 
event is finished.
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rather than placing a video. Note that the 
video must be compliant with the Flash 

Player. If the video is located on a web server, 
the URL is in the standard http:// format. 
However, if the video is hosted on a Flash 
Media Server or streaming service, the URL 
needs to be in the rtmp:// format.

If you click the PDF Export Options icon in 
the Media panel ( ), you’re given options to 
play the video in a floating window, scale it, 
and provide description text. The description 
is useful if there are difficulties playing the 
video. If the user is visually impaired the text 
will be read aloud by screen-reading software.

If the selected media file is a video, you can 
scrub through it using the play control under 
the video preview, and designate frames as 
Navigation Points. That way, you can use a 
button to trigger the video to start playing 
from a navigational point, leading the viewer 
directly to the desired segment of the video. 
The video will start from the navigation point, 
and play to the end of the video. 

The Media panel is also used to control 
the way audio files are represented and con-
trolled (Figure 8). If you intend to export to 

SWF, you’re limited to using MP3 audio files. 
If you’re aiming for PDF instead, you can use 
AIFF and AVI files, but InDesign alerts you 
that those formats will only survive the trip 
to PDF, not SWF. 

Once you place a sound file, you use 
InDesign’s Media panel to preview the audio, 
set the audio to play on page load (if you 
haven’t provided another trigger, such as 
a button), and control whether it loops or 

plays multiple times. The Stop on Page Turn 
option silences the sound when the viewer 
navigates to another page, which prevents a 
sound from interfering from audio triggered 
on the next page displayed. 

As with videos, you can choose to have 
no poster, use the standard “speaker” icon, 
or specify a graphic to represent the sound. 
You can also place an audio file in the paste-
board of the document, and it will still be 
included in an exported SWF. However, 
because it’s in the pasteboard, it won’t be 
included if you package the file; you’ll have 
to gather it up manually.

Object States
Multi-state objects are an interesting con-
cept: The Object States panel lets you store 
multiple versions of an object, the visibility 
of which you usually control with buttons. 
States can differ in image content, effects, 
opacity, blending mode, position, and rota-
tion. If you scale the object, it affects all states. 
Perhaps the most common use of a multi-
state object is to create a slideshow effect, 
but it’s also a nice solution to a need to dis-Figure 8: Using the Media panel to control audio content.
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play alternating images in a page, say, as 
illustrations for the steps of a how-to guide. 
To create a three-state multi-state object 

that is a slideshow, take the following steps:
1. Create a frame, right-click and choose Fit-

ting > Fill Frame Proportionally. Duplicate 
the frame to make two copies (for a total of 
three). Place an image in each frame.

2. Select all three frames: Don’t group them, 
just select them. Align the objects’ top and 
left edges, and keep the objects selected.

3. Open the Object States panel (Window > 
Interactive > Object States).

4. Click the “Convert selection to multi-state 
object” icon ( ) at the bottom of the Ob-
ject States panel.

5. Name the object something you’ll remem-
ber when it comes time to target it, such 
as “slideshow.”

6. Now you need a button to trigger the 
slideshow. Create a new frame, fill it with 
the swatch of your choice, and convert it 
to a button: Right-click and choose Inter-
active > Convert to Button. 

7. Go to the Buttons panel and choose the 
On Release event, click the plus sign by 

Actions, and choose Go To Next State. Des-
ignate your “slideshow” multi-state object 
as the target.

8. Click the Preview icon at the bottom of the 
Buttons panel to render the spread in the 
Preview panel, and test the slideshow by 
clicking the button.

Note: Multi-state objects only work in ex-
ported SWF files; they don’t function in in-
teractive PDFs.

Buttons
Unless you want animations and multimedia 
content triggered upon page load (when a 
page turns), buttons are your friends. And 
they’re invaluable as navigation aids. When 
buttons were introduced in InDesign CS, 

they were represented by a dedicated tool, 
but that tool disappeared in CS4, replaced 
by the Buttons panel. While you can convert 
any object to a button by right-clicking and 
choosing Interactive > Convert to Button, 
InDesign ships with the same library of 52 
attractive buttons that were included with 
CS4 (Figure 9).  Just choose “Sample Buttons” 
from the Buttons panel menu. The sample 
buttons are named with numbers, 1 through 
52, and they already have attached actions 
(which you can easily modify or replace). 
Here’s a decoder ring explaining which 
actions are attached to which buttons:

Tip: Download a multi-state exercise file 

from my wesbite: http://www.practicalia.

net/idmag/multistate.zip . You can prac-

tice on it until you’re ready to create a 

multi-state object for paying clients.

Figure 9: InDesign provides 52 pre-fab buttons for your 
click ing pleasure.

http://www.practicalia.net/idmag/multistate.zip
http://www.practicalia.net/idmag/multistate.zip


TIP: If you have your heart set on 

some of the features that don’t export 

to interactive PDF, there’s a work-

around. Export content as SWF, then 

place it back into an InDesign file as 

multimedia content and export as 

PDF. Even cooler: Check out this arti-

cle by James Fritz, describing the great 

“SWF Presenter” script from Martinho 

da Gloria, author of the nifty Layout 

Zone script: http://bit.ly/cHuxyh
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 ❱ Buttons 1 and 2: These two library en-
tries consist of multiple buttons grouped 
into navigational bars. All buttons use the 
Go to Page action, which works in ex-
ported SWF files but does nothing in an 
exported PDF. (InDesign warns you if you 
attempt to export a PDF from a file con-
taining buttons with Go to Page actions 
attached.) But think of these initial actions 
as just placeholders; you can change them 
to whatever actions you need. 

 ❱ Buttons 3-12: All of these buttons have 
Go to URL actions, which can take the user 
to a Web address, or invoke a mailto ad-
dress to launch an e-mail application. The 
Go to URL actions work in both SWF and 
PDF export.

 ❱ Buttons 13-22: These buttons are set to 
the Go to Page action.

 ❱ Buttons 23-32: These are set to the Go to 
URL action.

 ❱ Buttons 33-51 (odd numbers): The odd-
numbered buttons are all left-pointing, 
which gives a hint about their function—
they all use the Go to Previous Page action, 
which works in both SWF and PDF export.

 ❱ Buttons 34-52 (even numbers): All right-
pointing, even-numbered buttons in this 
range use the Go to Next Page action.

To use one of the sample buttons, just drag 
it into the page and modify its attributes in 
the Buttons panel.

Exporting
Eventually you’ll want to send your project 
out for others to enjoy. When you go to File 
> Export, you can choose from Adobe PDF 
(Interactive), Flash CS5 Professional (FLA), and 
Flash Player (SWF). 

If you export to PDF, only navigation con-
trols, hyperlinks, page transitions, rollovers 
(Show/Hide fields), and placed multimedia 
survive the trip. Any animations applied to 
page objects will be lost in an exported inter-
active PDF: Acrobat doesn’t think type should 
fly. And multi-state objects are inert in PDFs. 
The button actions Go To Page, Go To State, 
Go To Next State, and Go To Previous State 
don’t survive the trip, either.  

If you export to FLA, a Flash developer will 
have to reconstitute some attributes (such 
as “stop” commands to keep animations from 
cycling endlessly). But the Flash export does 
gather up all the bits and pieces (such as 
multimedia content) in a Resources folder 
inside the export folder; the developer needs 
access to these resources to further enhance 

Fearless Flash: For more 
detailed exploration of the 
interactive capabilities of 
InDesign CS5 (with some 
Flash Catalyst and Flash 
Professional thrown in), get 
Claudia’s new book, Fearless 
Flash: Use Adobe InDesign 
CS5 and the Tools You Already 
Know to Create Engaging Web 
Documents. 

http://bit.ly/cHuxyh
http://www.amazon.com/Fearless-Flash-InDesign-Engaging-Documents/dp/0321734823/ref=sr_1_1?ie=UTF8&s=books&qid=1287601038&sr=1-1
http://www.amazon.com/Fearless-Flash-InDesign-Engaging-Documents/dp/0321734823/ref=sr_1_1?ie=UTF8&s=books&qid=1287601038&sr=1-1
http://www.amazon.com/Fearless-Flash-InDesign-Engaging-Documents/dp/0321734823/ref=sr_1_1?ie=UTF8&s=books&qid=1287601038&sr=1-1
http://www.amazon.com/Fearless-Flash-InDesign-Engaging-Documents/dp/0321734823/ref=sr_1_1?ie=UTF8&s=books&qid=1287601038&sr=1-1
http://www.amazon.com/Fearless-Flash-InDesign-Engaging-Documents/dp/0321734823/ref=sr_1_1?ie=UTF8&s=books&qid=1287601038&sr=1-1
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Slash	the	time	it	takes	to	clean	up	after	you’ve	exported	
text	 from	 an	 InDesign	 file,	 thanks	 to	 Rorohiko’s	
TextExporter	for	Adobe®	InDesign®.
A	 time-limited,	 fully	 functional	 demo	 version	 can	 be	
found	at:
http://www.rorohiko.com/textexporter
Download	 it	 today	 and	 try	 it	 out	 for	 free	 for	 about	 a	
month.
TextExporter	will	harvest	text	from	the	text	frames	of	the	
document.	It	will	then	clean	up	the	text	and	concatenate	
the	fragments	in	a	sensible	sequence.	It	can	automatically	
omit	short	text	frames	which	don’t	belong	in	the	export.
Text	 can	 be	 exported	 to	 RTF,	 plain	 text	 or	 InDesign	
Tagged	Text	Format.
The	 advantage	 of	 TextExporter	 is	 its	 smart	 text	
concatenation.	The	resulting	file	is	most	often	usable	as-
is,	and	you	don’t	waste	valuable	time	cutting	and	pasting	
exported	text	into	a	more	concise	whole.
Use	 coupon	 code	 IDMAG2010D	 when	 purchasing	
to	 get	 US$5.00	 off	 the	 regular	 US$19.00	 price.	 This	
coupon	code	may	be	used	once	per	InDesign	Magazine	
subscription.	Offer	expires	after	December	31,	2010.

TextExporter
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your project. Any image or vector content 
is automatically embedded in the FLA file, 

as Library items. The exported FLA file is fully 
editable in Flash Professional.

When you export to SWF, all interactive 
content is maintained, including multi-state 
objects and animated page objects. The 
default options in the SWF export dialog will 
usually serve you well, although you’ll want 
to deselect the Interactive Page Curl option 
if you’re using page navigation buttons near 
the corners of the pages; they fight for control.

By default, InDesign generates a compan-
ion HTML file during the SWF export, which 
makes it easy for you to preview the SWF by 
launching a browser and opening the HTML 
file. All multimedia content is stored in a sup-
port folder named [SWF filename]_Resources. 
If you’re going to deploy the whole shebang, 
remember to include the HTML file, the SWF 
file, and the Resources folder.

I Did It In InDesign
The animation capabilities in InDesign CS5 
are quite robust—and a lot of fun. It’s so cool 
to be able to say, “I did this in InDesign.” Or 
don’t tell your client at all and let them ooh 
and ahh over your interactive brilliance!

Claudia McCue is a consultant, trainer, and graphic arts 

production expert. With more than 20 years of real-world 

production experience, she specializes in teaching both 

creative and production professionals. Her national client 

base includes printers, design firms, agencies, and in-

house marketing departments. She is the author of Real 

World Print Production with Adobe Creative Suite Applications 

and a frequent presenter at graphic arts conferences. 

She is an Adobe Certified Instructor for Photoshop, 

Acrobat, Illustrator, and InDesign. Read her blogs at www.

claudiamccue.com and www.motobroad.com. For training, 

visit www.practicalia.net.

http://www.rorohiko.com/textexporter
http://www.amazon.com/exec/obidos/ASIN/032163683X/creativeprocom/
http://www.amazon.com/exec/obidos/ASIN/032163683X/creativeprocom/
http://www.claudiamccue.com
http://www.claudiamccue.com
http://www.motobroad.com
http://www.practicalia.net


Help a Friend
And help yourself, too. Here are two great dicounts on

InDesign Magazine that anyone can enjoy: $20 off of a

one-year subscription (coupon code FRIEND), or $15 off a 

two-year subscription (coupon code FRIEND2). Send them 

to www.indesignmag.com/purchase.php.
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