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Lesson overview
In this lesson, you’ll learn how to do the following: 

• Use guides to position text in a composition.

• Make a clipping mask from type.

• Merge type with other layers.

• Format text.

• Distribute text along a path.

• Create and apply type styles.

• Control type and positioning using advanced features.

This lesson will take less than an hour to complete. Copy the Lesson07 
folder onto your hard drive if you haven’t already done so. As you work 
on this lesson, you’ll preserve the start files. If you need to restore the 
start files, copy them from the Adobe Photoshop CS6 Classroom in a  
Book DVD.

7
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Photoshop provides powerful, flexible text tools so 
you can add type to your images with great control 
and creativity.
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188 lesson 7 typographic design

about type
Type in Photoshop consists of mathematically defined shapes that describe the let-
ters, numbers, and symbols of a typeface. Many typefaces are available in more than 
one format, the most common formats being Type 1 or PostScript fonts, TrueType, 
and OpenType (see “OpenType in Photoshop” later in this lesson).

When you add type to an image in Photoshop, the characters are composed of  
pixels and have the same resolution as the image file—zooming in on characters 
shows jagged edges. However, Photoshop preserves the vector-based type outlines 
and uses them when you scale or resize type, save a PDF or EPS file, or print the 
image to a PostScript printer. As a result, you can produce type with crisp, reso-
lution-independent edges, apply effects and styles to type, and transform its shape 
and size.

Getting started
In this lesson, you’ll work on the layout for the cover of a technology magazine. 
You’ll start with the artwork you created in Lesson 6: The cover has a model, his 
shadow, and the orange background. You’ll add and stylize type for the cover, 
including warping the text.

You’ll start the lesson by viewing an image of the final composition.

1 Start Photoshop, and then immediately hold down Ctrl+Alt+Shift (Windows) 
or Command+Option+Shift (Mac OS) to restore the default preferences. (See 
“Restoring default preferences” on page 4.) 

2 When prompted, click Yes to delete the Adobe Photoshop Settings file.

3 Choose File > Browse In Bridge to open Adobe Bridge.

4 In the Favorites panel on the left side of Bridge, click the Lessons folder, and 
then double-click the Lesson07 folder in the Content panel.

5 Select the 07End.psd file. Increase the thumbnail size to see the image clearly  
by dragging the thumbnail slider to the right.

You’ll apply the type treatment in Photoshop to finish the magazine cover. All of 
the type controls you need are available in Photoshop, so you don’t have to switch 
to another application to complete the project.

 Note: Though this 
lesson starts where 
Lesson 6 left off, use the 
07Start.psd file. We’ve 
included a path and a 
sticky note in the start 
file that won’t be in 
the 06Working.psd file 
you saved.
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6 Double-click the 07Start.psd file to open  
it in Photoshop.

7 Choose File > Save As, rename the file 
07Working.psd, and click Save. 

8 Click OK if the Photoshop Format Options 
dialog box appears.

9 Choose Typography from the Workspace 
Switcher in the options bar. 

The Typography workspace displays the Character, 
Paragraph, Paragraph Styles, Layers, and Paths 
panels that you’ll use in this lesson.

Creating a clipping mask from type
A clipping mask is an object or a group of objects whose shape masks other artwork 
so that only areas that lie within the clipping mask are visible. In effect, you are 
clipping the artwork to conform to the shape of the object (or mask). In Photoshop, 
you can create a clipping mask from shapes or letters. In this exercise, you’ll use 
letters as a clipping mask to allow an image in another layer to show through 
the letters.

adding guides to position type
The 07Working.psd file includes a background layer, which will be the foundation 
for your typography. You’ll start by zooming in on the work area and using ruler 
guides to help position the type.

1 Choose View > Fit On Screen to see 
the whole cover clearly.

2 Choose View > Rulers to display 
rulers along the left and top borders 
of the image window. 

3 Drag a vertical guide from the left 
ruler to the center of the cover (4.25").
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adding point type
Now you’re ready to add type to the composition. Photoshop lets you create hori-
zontal or vertical type anywhere in an image. You can enter point type (a single  
letter, word, or line) or paragraph type. You will do both in this lesson. First, you’ll  
create point type.

1 In the Layers panel, select the Background layer.

2 Select the Horizontal Type tool ( ), and, in the options bar, do the following:

• Choose a sans serif typeface, such as Myriad Pro, from the Font Family 
pop-up menu, and choose Semibold from the Font Style pop-up menu.

• Type 144 pt for the Size, and press Enter or Return.

• Click the Center Text button.

3 In the Character panel, change the Tracking value to 100.

4 Click on the center guide you added to set an insertion point, and type 
DIGITAL in all capital letters. Then click the Commit Any Current Edits button 
( ) in the options bar. 

The word “DIGITAL” is added to the cover, and it appears in the Layers panel as 
a new type layer, DIGITAL. You can edit and manage the type layer as you would 
any other layer. You can add or change the text, change the orientation of the type, 
apply anti-aliasing, apply layer styles and transformations, and create masks. You 
can move, restack, and copy a type layer, or edit its layer options, just as you would 
for any other layer.
the 

5 Press Ctrl (Windows) or Command (Mac OS), and drag the “DIGITAL” text  
to move it to the top of the cover, if it’s not there already.

6 Choose File > Save to save your work so far. 

 Note: After you 
type, you must commit 
your editing in the layer 
by clicking the Commit 
Any Current Edits 
button or switching to 
another tool or layer. 
You cannot commit 
to current edits by 
pressing Enter or 
Return; doing so  
merely creates a  
new line of type. 
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Making a clipping mask and applying a shadow
You added the letters in black, the default text color. However, you want the letters 
to appear to be filled with an image of a circuit board, so you’ll use the letters to 
make a clipping mask that will allow another image layer to show through. 

1 Open the circuit_board.tif file, which is in the Lesson07 folder. You can open  
it using Bridge or by choosing File > Open.

2 In Photoshop, choose Window > Arrange > 2-Up Vertical. The circuit_board.tif 
and 07Working.psd files appear onscreen together. Click the circuit_board.tif 
file to ensure that it’s the active window. 

3 Select the Move tool. Then, hold down the Shift key as you drag the Background 
layer from the Layers panel in the circuit_board.tif file onto the center of the 
07Working.psd file. Pressing Shift as you drag centers the circuit_board.tif image 
in the composition.

A new layer—Layer 1— appears in the Layers panel for the 07Working.psd file. This 
new layer contains the image of the circuit board, which will show through the type. 
But before you make the clipping mask, you’ll resize the circuit board image, as it’s 
currently too large for the composition.

4 Close the circuit_board.tif file without saving any changes to it.

5 In the 07Working.psd file, select Layer 1, and then choose Edit > Transform > Scale. 

6 Grab a corner handle on the bounding box for the circuit board. Press Shift as 
you resize it to approximately the same width as the area of text. Pressing Shift 
retains the image proportions. Reposition the circuit board so that the image 
covers the text. 
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7 Press Enter or Return to apply the transformation.

8 Double-click the Layer 1 name, and change it to Circuit Board. Then press 
Enter or Return, or click away from the name in the Layers panel, to apply  
the change.

9 Select the Circuit Board layer, if it isn’t already selected, and choose Create 
Clipping Mask from the Layers panel menu ( ). 

The circuit board now shows through the DIGITAL letters. A small arrow in the 
Circuit Board layer and the underlined type layer name indicate the clipping mask 
is applied. Next, you’ll add an inner shadow to give the letters depth. 

10 Select the DIGITAL layer to make it active, click the Add A Layer Style button  
( ) at the bottom of the Layers panel, and then choose Inner Shadow from the 
pop-up menu. 

E Tip: You can also 
make a clipping mask 
by holding down 
the Alt (Windows) or 
Option (Mac OS) key 
and clicking between 
the Circuit Board and 
DIGITAL type layers.
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11 In the Layer Style dialog box, change the Blending Mode to Multiply, Opacity  
to 48%, Distance to 18, Choke to 0, and Size to 16. Then click OK.

12 Choose File > Save to save your work so far.

Julieanne Kost is an official Adobe Photoshop evangelist. 

tool tips from the Photoshop 
evangelist
type tool tricks

•  Shift-click in the image window with the Type tool (T) to create a new type 
layer—in case you’re close to another block of type and Photoshop tries to 
autoselect it.

•  Double-click the thumbnail icon on any type layer in the Layers panel to select 
all of the type on that layer. 

•  With any text selected, right-click (Windows) or Control-click (Mac OS) on the 
text to access the context menu. Choose Check Spelling to run a spell check.
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Creating type on a path
In Photoshop, you can create type that follows along a path you create with a  
pen or shape tool. The direction the type flows depends on the order in which 
anchor points were added to the path. When you use the Horizontal Type tool  
to add text to a path, the letters are perpendicular to the baseline of the path.  
If you change the location or shape of the path, the type moves with it.

You’ll create type on a path to make it look as if questions are coming from the 
model’s mouth. We’ve already created the path for you.

1 In the Layers panel, select the Background layer.

2 Select the Paths tab in the Layers panel group. 

3 In the Paths panel, select the path named Speech Path. The path appears  
to be coming out of the model’s mouth.

4 Select the Horizontal Type tool.

5 In the Character panel, select the following  
settings:

• Font Family: Myriad Pro

• Font Style: Regular

• Font Size ( ): 16 pt

• Tracking ( ): -10

• Color: White

• All Caps ( )

6 Move the Type tool over the path. When a small slanted line appears across  
the I-bar, click the beginning of the path, and type What’s new with Games?
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7 Select the word “GAMES,” and change its font style to Bold. Click the Commit 
Any Current Edits button ( ) in the options bar.

8 In the Layers panel, select the What’s New with Games layer, and then choose 
Duplicate Layer from the Layers panel menu. Name the new layer What’s new 
with MP3s?

9 With the Type tool, select “Games,” and replace it with MP3s. Click the Commit 
Any Current Edits button in the options bar.

10 Choose Edit > Free Transform. Rotate the left side of the path approximately 
30 degrees, and then shift the path up above the first path. Click the Commit 
Transform button in the options bar.
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11 Repeat steps 8–10, replacing the word “GAMES” with PHONES. Rotate the left 
side of the path approximately -30 degrees, and move it below the original path.

12 Choose File > Save to save your work so far.

Warping point type
The text on a path is more interesting than straight lines would be, but you’ll warp 
the text to make it more playful. Warping lets you distort type to conform to a vari-
ety of shapes, such as an arc or a wave. The warp style you select is an attribute of 
the type layer—you can change a layer’s warp style at any time to change the overall 
shape of the warp. Warping options give you precise control over the orientation 
and perspective of the warp effect.

1 Scroll or use the Hand tool ( ) to move the visible area of the image window  
so that the sentences to the left of the model are in the center of the screen. 

2 Right-click (Windows) or Control-click (Mac OS) the What’s new with Games? 
layer in the Layers panel, and choose Warp Text from the context menu.
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3 In the Warp Text dialog box, choose Wave from the Style menu, and select 
the Horizontal option. Specify the following values: Bend, +33%; Horizontal 
Distortion, -23%; and Vertical Distortion, +5%. Then click OK.

The words “What’s new with games?” appear to float like a wave on the cover. 
Repeat steps 2 and 3 to warp the other two text layers you typed on a path.

4 Save your work.

Designing paragraphs of type
All of the text you’ve written on this cover so far has been a few discrete words or 
lines—point type. However, many designs call for full paragraphs of text. You can 
design complete paragraphs of type in Photoshop; you can even apply paragraph 
styles. You don’t have to switch to a dedicated page layout program for sophisticated 
paragraph type controls. 

using guides for positioning
You will add paragraphs to the cover in Photoshop. First, you’ll add some guides to 
the work area to help you position the paragraph, and create a new paragraph style.

1 Drag a guide from the left vertical 
ruler, placing it approximately 1/4" 
from the right side of the cover.

2 Drag a guide down from the 
top horizontal ruler, placing it 
approximately 2" from the top of the 
cover.
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adding paragraph type from a sticky note
You’re ready to add the text. In a real design environment, the text might be 
provided to you in a word-processing document or the body of an email message, 
which you could copy and paste into Photoshop. Or you might have to type it in. 
Another easy way to add a bit of text is for the copywriter to attach it to the image 
file in a sticky note, as we’ve done for you here.

1 Double-click the yellow sticky note in the lower right corner of the image 
window to open the Notes panel. Expand the Notes panel, if necessary,  
to see all the text. 

2 In the Notes panel, select all the text. Press Ctrl+C (Windows) or Command+C 
(Mac OS) to copy the text to the clipboard. Close the Notes panel. 

3 Select the Model layer. Then, with the Horizontal Type tool ( ), drag a text box 
on the right side of the magazine cover. The text box should be about 4 inches by 
8 inches, about 1/4” from the right edge of the cover. Align the top and right edges 
using the guides you just added.

4 Press Ctrl+V (Windows) or Command+V (Mac OS) to paste the text. The  
new text layer is at the top of the Layers panel, so the text appears in front of  
the model. 

The pasted text is huge, because your default is set to 144 pt text. You’ll change  
it all to a readable size before stylizing it.

5 Click in the pasted text, and press Ctrl+A (Windows) or Command+A (Mac OS) 
to select all the text. Then change its size to 18 pt in the Character panel.

E Tip: If you 
accidentally select the 
“DIGITAL” text, press 
Shift as you start to drag 
the text box, and then 
release it to continue 
to drag.  Pressing Shift 
ensures that Photoshop 
creates a new text layer. 
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6 Select the first three lines (“The Trend Issue”), and then apply the following 
settings in the Character panel:

• Font Family: Myriad Pro (or another sans serif font)

• Font Style: Regular

• Font Size ( ): 70 pt

• Leading ( ): 55 pt

• Color: White

7 Click the Paragraph tab in the Character panel group to make the Paragraph 
panel active.

8 With “The Trend Issue” still selected, click the Right Align Text option.

9 Click the Character tab to open the Character panel again. Then select just the 
word “Trend,” and change the Font Style to Bold. 

10 Click the Commit Any Current Edits button ( ) in the options bar.

11 Click in the blank area of the Layers panel to ensure that no layers are selected.

You’ve formatted the title. 

Creating paragraph styles
You’ll create a paragraph style to format the rest of the text. A paragraph style is a 
collection of type attributes that you can apply to an entire paragraph with a single 
click. Paragraph styles in Photoshop are similar to styles in page layout applications 
such as Adobe InDesign and popular word-processing applications, but you’ll prob-
ably notice some differences in the way they work. By default, all text you create in 
Photoshop has the Basic paragraph style applied.
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1 Click the Create New Paragraph Style button ( )  at the bottom of the 
Paragraph Styles panel.

2 Double-click Paragraph Style 1 to change its attributes.

3 In the Paragraph Style Options dialog box, specify the following settings:

• Style Name: Cover Teasers

• Font Family: Myriad Pro

• Font Style: Bold

• Font Size: 28 pt

• Leading: 28 pt 

• Color: White

4 Select Indents And Spacing from the list on the left in the Paragraph Style 
Options dialog box.

5  Choose Right from the Alignment menu, and then click OK.

You’ve created a style that you can apply to quickly format the teaser titles on the 
cover. You’ll create another style for the subheadings, which should be smaller.

6 Click the Create New Paragraph Style button at the bottom of the Paragraph 
Styles panel again.

7 Double-click Paragraph Style 1, and then specify the following:

• Style Name: Teaser subheads

• Font Family: Myriad Pro

• Font Style: Regular

• Font Size: 22 pt

• Leading: 28 pt 

• Color: White
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8 Select Indents And Spacing from the list on the left in the Paragraph Style 
Options dialog box.

9  Choose Right from the Alignment menu, and then click OK.

applying paragraph styles
Applying a paragraph style is easy. With the text selected, simply click the style 
name. If the text has been changed from the Basic paragraph style, Photoshop 
retains those overrides and applies only the attributes of the style that do not con-
flict with the overrides. In that case, clear overrides to apply all the style’s attributes.

1 Select the “What’s Hot” text, and then select Cover Teasers in the Paragraph 
Styles panel.

Photoshop applies some of the Cover Teasers attributes to the paragraph, but not  
all of them because there were style overrides in effect when you applied the style.

2 Click the Clear Override button ( ) at the bottom of the Paragraph Styles panel.

3 Select the text beneath “What’s Hot,” and then select Teaser subheads in the 
Paragraph Styles panel. Click the Clear Override button again.

4 Repeat steps 1–3 for the “What’s Not” and “Coming this year” sections.

Now there is just one more change to make to specific areas of the text.

5 Select “Coming this year” and all the text that 
follows it. Then, in the Character panel, change 
the text color to Black.

6 Finally, click the Commit Any Current Edits 
button to accept the type changes.

Excerpted from Adobe Photoshop CS6 Classroom in a Book.  
Copyright © 2012 Adobe Systems Incorporated. Used with permission of Pearson Education and Adobe Press.



202 lesson 7 typographic design

Opentype in Photoshop
OpenType is a cross-platform font file format developed jointly by Adobe and 
Microsoft. The format uses a single font file for both Mac OS and Windows, so you 
can move files from one platform to another without font substitution or reflowed 
text. OpenType offers widely expanded character sets and layout features, such as 
swashes and discretionary ligatures, that aren’t available in traditional PostScript 
and TrueType fonts. This, in turn, provides richer linguistic support and advanced 
typography control. Here are some highlights of OpenType. 

The OpenType menu The Character panel menu includes an OpenType submenu  
that displays all available features for a selected OpenType font, including ligatures, 
alternates, and fractions. Dimmed features are unavailable for that typeface;  
a check mark appears next to features that have been applied.

Discretionary ligatures To add a discretionary ligature to two OpenType letters,  
such as to “th” in the Bickham Script Standard typeface, select them in the image,  
and choose OpenType > Discretionary Ligatures from the Character panel menu. 

Swashes Adding swashes or alternate characters works the same way. Select the 
letter, such as a capital “T” in Bickham Script, and choose OpenType > Swash to 
change the ordinary capital into a dramatically ornate swash T. 

Creating true fractions Type fractions as usual—for example, 1/2—and then select 
the characters, and from the Character panel menu, choose OpenType > Fractions. 
Photoshop applies the true fraction (1/2).

adding vertical type
You’re almost done with the text for the magazine cover. All that remains to do is to 
add the volume number in the upper right corner. You’ll use vertical type to add it.

1 Choose Select > Deselect Layers. Then select the Vertical Type tool ( ), which 
is hidden under the Horizontal Type tool.

2 Press the Shift key, and begin dragging in the upper right corner of the cover, 
near the letter “L.” Release the Shift key, and drag a vertical rectangle. 

Pressing the Shift key as you begin dragging ensures that you create a new text box 
instead of selecting the title.

3 Type VOL 9.

E Tip: Use the Adobe 
Illustrator Glyphs panel 
to preview OpenType 
options: Copy your text 
in Photoshop and paste 
it into an Illustrator 
document. Then, 
choose Window > 
Type > Glyphs.  
Select the text you  
want to change, 
and choose Show > 
Alternates For Current 
Selection. Double-click 
a glyph to apply it, and 
when you’ve finished, 
copy and paste the 
new type into your 
Photoshop file. 
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4 Select the letters either by dragging or triple-clicking them, and then, in the 
Character panel, select the following:

•  Font Family: a serif typeface, such as Myriad Pro

•  Font Style: a light or narrow style, such as Light Condensed

•  Font size: 15 pt

•  Tracking: 150

•  Color: Black

5 Click the Commit Any Current Edits button ( ) in the options bar.  
Your vertical text now appears as the layer named VOL 9. Use the Move  
tool ( ) to drag it to the right, if necessary.

Now, you’ll clean up a bit.

6 Click the note to select it. Then right-click (Windows) or Control-click  
(Mac OS) and choose Delete Note from the context menu; click Yes to confirm 
that you want to delete the note. 

7 Hide the guides: Choose the Hand tool ( ), and then press Ctrl+; (Windows)  
or Command+; (Mac OS). Then zoom out to get a nice look at your work.
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8 Choose File > Save to save your work.

Congratulations! You’ve added and stylized all of the type on the Digital magazine 
cover. Now that the magazine cover is ready to go, you’ll flatten it and prepare it  
for printing.

9 Choose File > Save As, rename the file 07Working_flattened, and click Save. 
Click OK if you see the Photoshop Format Options dialog box. 

Keeping a layered version lets you return to the 07Working.psd file in the future  
to edit it.

10 Choose Layer > Flatten Image.

11 Choose File > Save, and then close the image window.
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review questions
1 How does Photoshop treat type?

2 How is a text layer the same as or different from other layers in Photoshop? 

3 What is a clipping mask, and how do you make one from type?

4 What is a paragraph style?

review answers
1 Type in Photoshop consists of mathematically defined shapes that describe the letters, 

numbers, and symbols of a typeface. When you add type to an image in Photoshop, 
the characters are composed of pixels and have the same resolution as the image file. 
However, Photoshop preserves the vector-based type outlines and uses them when you 
scale or resize type, save a PDF or EPS file, or print the image to a PostScript printer.

2 Type that is added to an image appears in the Layers panel as a text layer that can be 
edited and managed in the same way as any other kind of layer. You can add and edit 
the text, change the orientation of the type, and apply anti-aliasing as well as move, 
restack, copy, and change the options for layers.

3 A clipping mask is an object or group whose shape masks other artwork so that only 
areas that lie within the shape are visible. To convert the letters on any text layer to  
a clipping mask, select both the text layer and the layer you want to show through the 
letters, and then choose Create Clipping Mask from the Layers panel menu.

4 A paragraph style is a collection of type attributes that you can quickly apply to an 
entire paragraph.
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